Skip to main content
Public proof of conceptFix available

CVE-2022-34918

A public proof of concept exists; no exploitation attested.

  • Published2022-07-04
  • Fixed in5.18.11 · 5.15.54 · 5.10.130 · 5.4.244 · 4.19.284 · 4.14.316
  • WeaknessCWE-843

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in the Linux kernel through 5.18.9. A type confusion bug in nft_set_elem_init (leading to a buffer overflow) could be used by a local attacker to escalate privileges, a different vulnerability than CVE-2022-32250. (The attacker can obtain root access, but must start with an unprivileged user namespace to obtain CAP_NET_ADMIN access.) This can be fixed in nft_setelem_parse_data in net/netfilter/nf_tables_api.c.

Timeline

dates in UTC
  1. 2022-07-0421:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-34918?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-34918?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Linux linux kernel
BranchAffectedFixed in
5.x≥ 5.16, < 5.18.115.18.11
5.x≥ 5.11, < 5.15.545.15.54
5.x≥ 5.5, < 5.10.1305.10.130
5.4≥ 4.20, < 5.4.2445.4.244
4.x≥ 4.15, < 4.19.2844.19.284
4.x≥ 4.1, < 4.14.3164.14.316
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
20.4= 20.04no fix published
22.4= 22.04no fix published
Debian debian linux
BranchAffectedFixed in
11.0= 11.0no fix published

5 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • dtb-aarch64openSUSE:Leap 15.4all versions · fixed in 5.14.21-150400.24.11.1and 10 other packages
  • dtb-aarch64openSUSE:Leap 15.4all versions · fixed in 5.3.18-150300.59.87.1
  • dtb-aarch64openSUSE:Leap 15.3all versions · fixed in 5.3.18-150300.59.87.1and 11 other packages
  • kernelTuxCare:CentOS:8.5all versions · fixed in 4.18.0-348.7.1.el8_5.tuxcare.els11and 21 other packages
  • kernelTuxCare:CentOS:8.4all versions · fixed in 4.18.0-305.25.1.el8_4.tuxcare.els11and 21 other packages
  • kernelRed Hat:enterprise_linux:9::baseosall versions · fixed in 0:5.14.0-70.26.1.el9_0and 27 other packages
  • kernelopenEuler:22.03-LTSall versions · fixed in 5.10.0-60.46.0.74.oe2203
  • kernelopenEuler:20.03-LTS-SP3all versions · fixed in 4.19.90-2207.3.0.0159.oe1

178 more package ranges on OSV.dev

Vendor advisories

  • CVE-2022-34918 Red Hat Product Security217 products fixed

    kernel: heap overflow in nft_set_elem_init()

  • ICSA-24-046-11 CISA11 known affected

    Siemens SCALANCE XCM-/XRM-300

    SCALANCE XCH328 (6GK5328-4TS01-2EC2) · SCALANCE XCM324 (6GK5324-8TS01-2AC2) · SCALANCE XCM328 (6GK5328-4TS01-2AC2) · +8 more

  • SSA-806742 Siemens ProductCERT11 known affected

    SSA-806742: Multiple Vulnerabilities in SCALANCE XCM-/XRM-300 before V2.4

    SCALANCE XCH328 (6GK5328-4TS01-2EC2) · SCALANCE XCM324 (6GK5324-8TS01-2AC2) · SCALANCE XCM328 (6GK5328-4TS01-2AC2) · +8 more

  • ICSA-23-166-11 CISA1 known affected

    Siemens SIMATIC S7-1500 TM MFP Linux Kernel

    SIMATIC S7-1500 TM MFP - GNU/Linux subsystem

  • SSA-794697 Siemens ProductCERT1 known affected

    SSA-794697: Vulnerabilities in the Additional GNU/Linux Subsystem of the SIMATIC S7-1500 TM MFP Before V1.1

    SIMATIC S7-1500 TM MFP - GNU/Linux subsystem < V1.1

  • RHSA-2022:6610 Red Hat Product Security166 products fixed

    Red Hat Security Advisory: kernel security, bug fix, and enhancement update

2 more advisories

Full record on NVD

Fix

  1. Update Linux linux kernel to 5.18.11 · 5.15.54 · 5.10.130 · 5.4.244 · 4.19.284 · 4.14.316
  2. Vendor fix Siemens ProductCERT SSA-806742 · 10 productsUpdate to V2.4 or later version
  3. Vendor fix CISA ICSA-24-046-11 · 10 productsUpdate to V2.4 or later version
  4. Vendor fix CISA ICSA-23-166-11 · 1 productUpdate to V1.1 or later version
  5. Vendor fix Siemens ProductCERT SSA-794697 · 1 productUpdate to V1.1 or later version
  6. Vendor fix Red Hat Product Security RHSA-2022:6610 · 166 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 The system must be rebooted for this update to take effect.
  7. Vendor fix Red Hat Product Security RHSA-2022:6592 · 21 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/local/netfilter_nft_set_elem_init_privescrank: averageModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2022-07-04
Last Modified
2026-10-14
NVD status
Modified
GitHub Advisory
GHSA-9v26-h3ph-p8v7

Frequently asked questions

What is CVE-2022-34918?

An issue was discovered in the Linux kernel through 5.18.9. A type confusion bug in nft_set_elem_init (leading to a buffer overflow) could be used by a local attacker to escalate privileges, a different vulnerability than CVE-2022-32250. (The attacker can obtain root access, but must start with an unprivileged user namespace to obtain CAP_NET_ADMIN access.) This can be fixed in nft_setelem_parse_data in net/netfilter/nf_tables_api.c.

Is CVE-2022-34918 actively exploited?

Active exploitation of CVE-2022-34918 has not been confirmed. Its EPSS score was 5.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2022-34918?

CVE-2022-34918 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running Linux kernel? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record