Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-44877

Exploitation confirmed. First attested on 2023-01-17 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2023-01-05
  • Fixed in0.9.8.1147
  • WeaknessCWE-78

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

login/index.php in CWP (aka Control Web Panel or CentOS Web Panel) 7 before 0.9.8.1147 allows remote attackers to execute arbitrary OS commands via shell metacharacters in the login parameter.

Timeline

dates in UTC
  1. 2023-01-0523:15CVE publishedNVD
  2. 2023-01-17Added to the CISA KEV catalogCISA KEV
  3. 2023-01-17Listed as exploited by GCVEGCVE
  4. 2023-01-17Exploitation first reportedCISA KEV
  5. 2023-04-01Exploit-DB entryExploit-DB
  6. 2025-01-2915:24SSVC exploitation set to activeCISA-ADP

Versions per branch

NVD
Control-webpanel webpanel
BranchAffectedFixed in
0.9< 0.9.8.11470.9.8.1147

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Control-webpanel webpanel to 0.9.8.1147
  2. CISA’s required action: Apply updates per vendor instructions.due 2023-02-07

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-51194EDB-51250
Exploit-DB
Metasploit modules
1 moduleexploit/linux/http/control_web_panel_login_cmd_execrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2023-01-17
Patch Due Date
2023-02-07
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-01-05
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-fxw7-8r5q-w2v4

Frequently asked questions

What is CVE-2022-44877?

login/index.php in CWP (aka Control Web Panel or CentOS Web Panel) 7 before 0.9.8.1147 allows remote attackers to execute arbitrary OS commands via shell metacharacters in the login parameter.

Is CVE-2022-44877 actively exploited?

Yes. CVE-2022-44877 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2023-02-07.

What is the CVSS score for CVE-2022-44877?

CVE-2022-44877 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record