Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-24112

Exploitation confirmed. First attested on 2022-08-25 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2022-02-11
  • Fixed in2.12.1 · 2.10.4
  • WeaknessCWE-290

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Timeline

dates in UTC
  1. 2022-02-1113:15CVE publishedNVD
  2. 2022-03-16Exploit-DB entryExploit-DB
  3. 2022-08-25Added to the CISA KEV catalogCISA KEV
  4. 2022-08-25Listed as exploited by GCVEGCVE
  5. 2022-08-25Exploitation first reportedCISA KEV
  6. 2025-01-2921:21SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-24112?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-24112?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Apache apisix
BranchAffectedFixed in
2.x≥ 2.11.0, < 2.12.12.12.1
2.10< 2.10.42.10.4

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Apache Software Foundation Apache APISIX
    Affected
    • ≥ Apache APISIX 2.12, < 2.12.1fixed in 2.12.1custom
    • ≥ Apache APISIX 2.10, < 2.10.4fixed in 2.10.4custom
    • ≥ 1.3, < Apache APISIX 1*fixed in Apache APISIX 1*custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-03-16

Fix

  1. Update Apache apisix to 2.12.1 · 2.10.4
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-09-15

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-50829
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/apache_apisix_api_default_token_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-08-25
Patch Due Date
2022-09-15
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-02-11
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-2vc7-6w39-6rh2

Frequently asked questions

What is CVE-2022-24112?

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Is CVE-2022-24112 actively exploited?

Yes. CVE-2022-24112 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-09-15.

What is the CVSS score for CVE-2022-24112?

CVE-2022-24112 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running apisix? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record