Skip to main content
No exploitation reportedFix available

CVE-2022-24437

No exploitation reported by the sources we read.

  • Published2022-05-01
  • Fixed in2.0.2
  • WeaknessCWE-88

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.

Timeline

dates in UTC
  1. 2022-05-0116:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-24437?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-24437?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Git-pull-or-clone project git-pull-or-clone
BranchAffectedFixed in
2.0< 2.0.22.0.2

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Git-pull-or-clone project git-pull-or-clone to 2.0.2

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.19.8known since 2026-10-23
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-88read 2026-10-23
  • FIRST EPSSEPSS score3.7 %2026-11-03
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryCRITICAL2022-05-23

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-05-01
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-3x62-x456-q2vm

Frequently asked questions

What is CVE-2022-24437?

The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.

Is CVE-2022-24437 actively exploited?

Active exploitation of CVE-2022-24437 has not been confirmed. Its EPSS score was 3.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2022-24437?

CVE-2022-24437 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running git-pull-or-clone? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record