Skip to main content
No exploitation reportedFix available

CVE-2020-36846

No exploitation reported by the sources we read.

  • Published2025-05-30
  • Fixed in1.0.8

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library.  Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1.0.8, where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your IO::Compress::Brotli module to 0.007 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Timeline

dates in UTC
  1. 2025-05-3001:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-10-28 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-36846?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-36846?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV
brotli
BranchAffectedFixed in
1.0< 1.0.81.0.8
brotli
BranchAffectedFixed in
1.0< 1.0.81.0.8
Microsoft.NETCore.App.Runtime.linux-arm
BranchAffectedFixed in
6.0≥ 6.0.0, < 6.0.36.0.3
5.0≥ 5.0.0, < 5.0.155.0.15
3.x≥ 3.0.0, < 3.1.233.1.23

121 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update brotli to 1.0.8

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub

Sources

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2025-05-30
Last Modified
2026-06-17
NVD status
Deferred

Frequently asked questions

What is CVE-2020-36846?

A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library.  Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1.0.8, where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your IO::Compress::Brotli module to 0.007 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Is CVE-2020-36846 actively exploited?

Active exploitation of CVE-2020-36846 has not been confirmed. Its EPSS score was 0.7% on 2026-10-26, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-36846?

CVE-2020-36846 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running brotli? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month