Skip to main content
No exploitation reportedFix available

CVE-2020-8927

No exploitation reported by the sources we read.

  • Published2020-09-15
  • WeaknessCWE-120 · CWE-130

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Timeline

dates in UTC
  1. 2020-09-1510:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-10-28 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-8927?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-8927?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Fedoraproject fedora
BranchAffectedFixed in
31.x= 31no fix published
32.x= 32no fix published
33.x= 33no fix published
34.x= 34no fix published
35.x= 35no fix published
36.x= 36no fix published
Microsoft powershell
BranchAffectedFixed in
7.2≥ 7.2, < 7.2.27.2.2
7.2≥ 7.2.0, < 7.2.27.2.2
7.1≥ 7.1, < 7.1.67.1.6
7.1≥ 7.1.0, < 7.1.67.1.6
7.0≥ 7.0, < 7.0.97.0.9
7.0≥ 7.0.0, < 7.0.97.0.9
Canonical ubuntu linux
BranchAffectedFixed in
16.4= 16.04no fix published
18.4= 18.04no fix published
20.4= 20.04no fix published

128 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • brotliAlmaLinux:8all versions · fixed in 1.0.6-3.el8and 2 other packages
  • dotnet-hostfxr-3.1AlmaLinux:8all versions · fixed in 3.1.23-1.el8_5and 5 other packages
  • dotnet-hostfxr-5.0AlmaLinux:8all versions · fixed in 5.0.15-1.el8_5and 5 other packages
  • dotnet-sdk-3.1AlmaLinux:8all versions · fixed in 3.1.417-1.el8_5and 2 other packages
  • dotnet-sdk-5.0AlmaLinux:8all versions · fixed in 5.0.212-1.el8_5and 2 other packages

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub

Sources

  • CISA-ADPSSVC decisionnone2025-05-30
  • OpenCVESSVC decisionnone—
  • CNACVSS 3.15.3read 2026-10-23
  • NVDCVSS 3.16.5read 2026-10-23
  • NVDCVSS 2.06.4read 2026-10-23
  • CNAweakness (CWE)CWE-130read 2026-10-23
  • NVDweakness (CWE)CWE-120read 2026-10-23
  • FIRST EPSSEPSS score3.2 %2026-10-26
  • OSVaffected packages—

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Published
2020-09-15
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2020-8927?

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Is CVE-2020-8927 actively exploited?

Active exploitation of CVE-2020-8927 has not been confirmed. Its EPSS score was 3.2% on 2026-10-26, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-8927?

CVE-2020-8927 has a CVSS v3 base score of 6.5 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L.

Running brotli? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month