Skip to main content
Public proof of conceptFix available

CVE-2026-111497

Node2Shell: Out-of-Bounds Write in Google Brotli Decoder

A public proof of concept exists; no exploitation attested.

  • Published2026-10-22
  • Fixed in1.2.1 · 1.1.1 · 1.0.10
  • WeaknessCWE-252 · CWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Timeline

dates in UTC
  1. 2026-10-2214:17CVE publishedNVD
  2. 2026-10-2318:46First public proof of conceptPoC-in-GitHub
  3. 2026-10-2523:12EPSS crossed 10 %FIRST EPSS

Observed activity

isMalicious corpus · updated 2026-10-28 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2026-111497?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2026-111497?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Google brotli
BranchAffectedFixed in
1.2≥ 1.2.0, < 1.2.11.2.1
1.2< 1.2.11.2.1
1.x≥ 1.0.3, < 1.2.11.2.1
1.1≥ 1.1.0, < 1.1.11.1.1
1.0≥ 1.0.3, < 1.0.101.0.10
Microsoft .net
BranchAffectedFixed in
10.0≥ 10.0.0, < 10.0.1410.0.14
9.0≥ 9.0.0, < 9.0.229.0.22
8.0≥ 8.0.0, < 8.0.338.0.33
11.0= 11.0.0no fix published
Node.js
BranchAffectedFixed in
26.12≥ 25.0.0, < 26.12.126.12.1
26.x≥ 26.0.0, < 26.12.126.12.1
24.22≥ 23.0.0, < 24.22.124.22.1
22.23< 22.23.422.23.4

13 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • brotliAlmaLinux:10all versions · fixed in 1.1.0-8.el10_2.1and 3 other packages
  • brotliAlmaLinux:9all versions · fixed in 1.0.9-10.el9_8.1and 3 other packages
  • brotliAlmaLinux:8all versions · fixed in 1.0.6-5.el8_10and 2 other packages

Vendor advisories

  • CVE-2026-111497 Red Hat Product Security479 products fixed · 87 known affected

    brotli: Out-of-Bounds Write in Google Brotli Decoder

    exploit-intelligence/vulnerability-analysis-rhel9 as a component of Exploit Intelligence · istio-proxy-selinux as a component of OpenShift Service Mesh 3 · istio-proxy.src as a component of OpenShift Service Mesh 3 · +84 more

  • RHSA-2026:87420 Red Hat Product Security13 products fixed

    Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Full record on NVD

Fix

  1. Update Google brotli to 1.2.1 · 1.1.1 · 1.0.10
  2. Vendor fix Red Hat Product Security CVE-2026-111497 · 8 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  3. Vendor fix Red Hat Product Security RHSA-2026:87420 · 13 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://images.redhat.com/
  4. Workaround from the vendor Red Hat Product Security RHSA-2026:87420 · 13 productsSee the security bulletin for a detailed mitigation procedure.

Advisories and patches

Detection

read 2026-10-28 00:45 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB

Sources

  • CISA-ADPSSVC decisionnone2026-10-23
  • OpenCVESSVC decisionactive—
  • CNACVSS 4.09.2read 2026-10-28
  • NVDCVSS 3.19.8read 2026-10-28
  • CNAweakness (CWE)CWE-252, CWE-787read 2026-10-28
  • FIRST EPSSEPSS score36.0 %read 2026-10-28
  • PoC-in-GitHubproof of concept20read 2026-10-28
  • OSVaffected packages—

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-10-22
Last Modified
2026-10-28
NVD status
Analyzed

Frequently asked questions

What is CVE-2026-111497?

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Is CVE-2026-111497 actively exploited?

Yes. CVE-2026-111497 has been observed in active exploitation according to SSVC analysis.

What is the CVSS score for CVE-2026-111497?

CVE-2026-111497 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running brotli? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month