Skip to main content
Public proof of conceptFix available

CVE-2018-16858

A public proof of concept exists; no exploitation attested.

  • Published2019-03-25
  • Fixed in6.1.3 · 6.0.7
  • WeaknessCWE-22 · CWE-356

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

It was found that libreoffice before versions 6.0.7 and 6.1.3 was vulnerable to a directory traversal attack which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document, which when opened by LibreOffice, would execute a Python method from a script in any arbitrary file system location, specified relative to the LibreOffice install location.

Timeline

dates in UTC
  1. 2019-03-2518:29CVE publishedNVD
  2. 2019-04-18Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-16858?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-16858?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Libreoffice
BranchAffectedFixed in
6.1≥ 6.1.0, < 6.1.36.1.3
6.0< 6.0.76.0.7

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • cppunitMageia:6all versions · fixed in 1.14.0-1.mga6
  • libabwMageia:6all versions · fixed in 0.1.2-1.mga6
  • libcdrMageia:6all versions · fixed in 0.1.5-1.mga6
  • libcmisMageia:6all versions · fixed in 0.5.2-1.mga6
  • libe-bookMageia:6all versions · fixed in 0.1.3-1.mga6
  • libepubgenMageia:6all versions · fixed in 0.1.1-2.mga6
  • libetonyekMageia:6all versions · fixed in 0.1.9-1.mga6
  • libfreehandMageia:6all versions · fixed in 0.1.2-2.mga6

76 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-16858 Red Hat Product Security1,640 products fixed · 133 known affected

    libreoffice: Arbitrary python functions in arbitrary modules on the filesystem can be executed without warning

    autocorr-af as a component of Red Hat Enterprise Linux 6 · autocorr-bg as a component of Red Hat Enterprise Linux 6 · autocorr-ca as a component of Red Hat Enterprise Linux 6 · +130 more

  • RHSA-2019:2130 Red Hat Product Security696 products fixed

    Red Hat Security Advisory: libreoffice security and bug fix update

Full record on NVD

Fix

  1. Update Libreoffice to 6.1.3 · 6.0.7
  2. Vendor fix Red Hat Product Security RHSA-2019:2130 · 696 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 All running instances of LibreOffice applications must be restarted for this update to take effect.
  3. No fix planned, says the vendor Red Hat Product Security CVE-2018-16858 · 133 productsOut of support scope

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-46727
Exploit-DB
Metasploit modules
1 moduleexploit/multi/fileformat/libreoffice_macro_execrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • CNACVSS 3.07.8known since 2026-10-23
  • NVDCVSS 3.09.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-356known since 2026-10-23
  • NVDweakness (CWE)CWE-22read 2026-10-23
  • FIRST EPSSEPSS score67.3 %read 2026-11-02
  • PoC-in-GitHubproof of concept4read 2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-03-25
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-16858?

It was found that libreoffice before versions 6.0.7 and 6.1.3 was vulnerable to a directory traversal attack which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document, which when opened by LibreOffice, would execute a Python method from a script in any arbitrary file system location, specified relative to the LibreOffice install location.

Is CVE-2018-16858 actively exploited?

Active exploitation of CVE-2018-16858 has not been confirmed. Its EPSS score was 67.3% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-16858?

CVE-2018-16858 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running libreoffice? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record