Skip to main content
ExploitedIn CISA KEVFix available

CVE-2018-7602

Exploitation confirmed. First attested on 2022-04-13 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2018-07-19
  • Fixed in8.5.3 · 8.4.8 · 7.59
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

Timeline

dates in UTC
  1. 2018-04-25Exploit-DB entryExploit-DB
  2. 2018-07-1917:29CVE publishedNVD
  3. 2022-04-13Added to the CISA KEV catalogCISA KEV
  4. 2022-04-13Listed as exploited by GCVEGCVE
  5. 2022-04-13Exploitation first reportedCISA KEV
  6. 2026-08-1303:55SSVC exploitation set to activeCISA-ADP

Versions per branch

NVD · OSV
Drupal
BranchAffectedFixed in
8.5≥ 8.5.0, < 8.5.38.5.3
8.5≥ 8.5, < 8.5.38.5.3
8.4≥ 8.4.0, < 8.4.88.4.8
8.x≥ 8.0.0, < 8.4.88.4.8
8.x≥ 8.0, < 8.4.88.4.8
7.x≥ 7.0, < 7.597.59
Debian debian linux
BranchAffectedFixed in
7.0= 7.0no fix published
8.0= 8.0no fix published
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As drupal, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Drupal coreother versions: not affected
    Affected
    • < 7.59fixed in 7.59custom
    • < 8.5.3fixed in 8.5.3custom
    • < 8.4.8fixed in 8.4.8custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-12-17

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • drupal7Ubuntu:Pro:16.04:LTSall versions · fixed in 7.44-1ubuntu1~16.04.0+esm1
  • drupal7Ubuntu:Pro:14.04:LTSall versions · fixed in 7.26-1ubuntu0.1+esm1
  • drupal7Debian:9all versions · fixed in 7.52-2+deb9u4
  • drupal7Debian:8all versions · fixed in 7.32-1+deb8u12
  • drupal7Debian:7all versions · fixed in 7.14-2+deb7u19
  • drupal7CleanStartall versions · fixed in 7.59-r0
  • drupal7Alpine:v3.20all versions · fixed in 7.59-r0
  • drupal7Alpine:v3.19all versions · fixed in 7.59-r0

13 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-7602 Red Hat Product Security

    drupal: Remote code execution vulnerability SA-CORE-2018-004

Full record on NVD

Fix

  1. Update Drupal to 8.5.3 · 8.4.8 · 7.59
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-04

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-44542EDB-44557
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-04-13
Patch Due Date
2022-05-04
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2018-07-19
Last Modified
2026-10-01
NVD status
Analyzed
GitHub Advisory
GHSA-297x-j9pm-xjgg

Frequently asked questions

What is CVE-2018-7602?

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

Is CVE-2018-7602 actively exploited?

Yes. CVE-2018-7602 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-04.

What is the CVSS score for CVE-2018-7602?

CVE-2018-7602 has a CVSS v3 base score of 8.1 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running drupal/core? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record