Skip to main content
ExploitedIn CISA KEVFix available

CVE-2018-7600

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2018-03-29
  • Fixed in8.5.1 · 8.4.6 · 8.3.9 · 7.58
  • WeaknessCWE-20

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Timeline

dates in UTC
  1. 2018-03-2907:29CVE publishedNVD
  2. 2018-04-13Exploit-DB entryExploit-DB
  3. 2021-11-03Added to the CISA KEV catalogCISA KEV
  4. 2021-11-03Listed as exploited by GCVEGCVE
  5. 2021-11-03Exploitation first reportedCISA KEV
  6. 2025-02-0712:40SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-7600?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-7600?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Drupal
BranchAffectedFixed in
8.5≥ 8.5.0, < 8.5.18.5.1
8.5≥ 8.5, < 8.5.18.5.1
8.4≥ 8.4.0, < 8.4.68.4.6
8.4≥ 8.4, < 8.4.68.4.6
8.x≥ 8.0.0, < 8.3.98.3.9
8.x≥ 8.0, < 8.3.98.3.9
7.x≥ 7.0, < 7.587.58
7.57≤ 7.57no fix published
Debian debian linux
BranchAffectedFixed in
7.0= 7.0no fix published
8.0= 8.0no fix published
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As drupal, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1
    Affected
    • = Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2018-06-11

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • drupal7Ubuntu:Pro:16.04:LTSall versions · fixed in 7.44-1ubuntu1~16.04.0+esm1
  • drupal7Ubuntu:Pro:14.04:LTSall versions · fixed in 7.26-1ubuntu0.1+esm1
  • drupal7Debian:9all versions · fixed in 7.52-2+deb9u3
  • drupal7Debian:8all versions · fixed in 7.32-1+deb8u11
  • drupal7Debian:7all versions · fixed in 7.14-2+deb7u18
  • drupal7CleanStartall versions · fixed in 7.58-r0
  • drupal7Alpine:v3.20all versions · fixed in 7.58-r0
  • drupal7Alpine:v3.19all versions · fixed in 7.58-r0

13 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-7600 Red Hat Product Security

    drupal: Unsanitized requests allow remote attackers to execute arbitrary code

Full record on NVD

Fix

  1. Update Drupal to 8.5.1 · 8.4.6 · 8.3.9 · 7.58
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-44448EDB-44449EDB-44482
Exploit-DB
Metasploit modules
1 moduleexploit/unix/webapp/drupal_drupalgeddon2rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2018-03-29
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-7fh9-933g-885p

Frequently asked questions

What is CVE-2018-7600?

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Is CVE-2018-7600 actively exploited?

Yes. CVE-2018-7600 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2018-7600?

CVE-2018-7600 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running drupal/drupal? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record