Skip to main content
Public proof of conceptFix availableAwaiting NVD analysis

CVE-2026-108097

Drupal core - Critical - Remote code execution - SA-CORE-2026-014

A public proof of concept exists; no exploitation attested.

  • Published2026-10-30
  • Fixed in12.0.0-beta2 · 11.4.10 · 11.3.19 · 10.6.19
  • WeaknessCWE-470

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Timeline

dates in UTC
  1. 2026-10-3003:09CVE publishedCNA
  2. 2026-10-3004:18CVE publishedNVD
  3. 2026-10-3101:00First public proof of conceptPoC-in-GitHub

Versions per branch

OSV
drupal/core
BranchAffectedFixed in
12.0≥ 12.0.0-alpha1, < 12.0.0-beta212.0.0-beta2
11.4≥ 11.4.0, < 11.4.1011.4.10
11.x≥ 11.0.0, < 11.3.1911.3.19
10.6≥ 8.9.0, < 10.6.1910.6.19

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As drupal, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Drupal core

    https://www.drupal.org/project/drupal

    Affected
    • ≥ 8.9.0, < 10.6.19fixed in 10.6.19semver
    • ≥ 11.0.0, < 11.3.19fixed in 11.3.19semver
    • ≥ 11.4.0, < 11.4.10fixed in 11.4.10semver
    • ≥ 12.0.0-alpha1, < 12.0.0-beta2fixed in 12.0.0-beta2semver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-10-30

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • drupal/coreTuxCare:Packagistfrom 10.5.12 · fixed in 10.5.12-p2+tuxcare
  • drupal/coreTuxCare:Packagistfrom 10.6.17 · fixed in 10.6.17-p1+tuxcare
  • drupal/coreTuxCare:Packagistfrom 8.9.20 · fixed in 8.9.20-p8+tuxcare
  • drupal/coreTuxCare:Packagistfrom 9.5.11 · fixed in 9.5.11-p7+tuxcare
  • drupal/coreRoot:Composerall versions · fixed in 9.8.0-p12007001+root.io

Full record on NVD

Fix

  1. Update drupal/core to 12.0.0-beta2 · 11.4.10 · 11.3.19 · 10.6.19

Detection

read 2026-11-01 01:02 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2026-10-30
Last Modified
2026-11-06
NVD status
Awaiting Analysis
GitHub Advisory
GHSA-x75q-mvwp-2h36

Frequently asked questions

What is CVE-2026-108097?

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

Is CVE-2026-108097 actively exploited?

Active exploitation of CVE-2026-108097 has not been confirmed. Its EPSS score was 0.3% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2026-108097?

CVE-2026-108097 has a CVSS v3 base score of 8.1 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running drupal/core? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record