Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-6340

Exploitation confirmed. First attested on 2022-03-25 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-02-21
  • Fixed in8.6.10 · 8.5.11 · 7.62.0
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Timeline

dates in UTC
  1. 2019-02-2121:29CVE publishedNVD
  2. 2019-02-23Exploit-DB entryExploit-DB
  3. 2022-03-25Added to the CISA KEV catalogCISA KEV
  4. 2022-03-25Listed as exploited by GCVEGCVE
  5. 2022-03-25Exploitation first reportedCISA KEV
  6. 2025-02-0712:38SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-6340?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-6340?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Drupal
BranchAffectedFixed in
8.6≥ 8.6.0, < 8.6.108.6.10
8.5≥ 8.5.0, < 8.5.118.5.11
8.x≥ 8.0.0, < 8.5.118.5.11
7.x≥ 7.0.0, < 7.62.07.62.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As drupal, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Drupal Core
    Affected
    • ≥ 8.5, < 8.5.11fixed in 8.5.11custom
    • ≥ 8.6, < 8.6.10fixed in 8.6.10custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2019-03-08

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Vendor advisories

  • CVE-2019-6340 Red Hat Product Security

    drupal: does not sanitize data from non-form sources leads to arbitrary PHP code execution

Full record on NVD

Fix

  1. Update Drupal to 8.6.10 · 8.5.11 · 7.62.0
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-04-15

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-46452EDB-46459EDB-46510
Exploit-DB
Metasploit modules
1 moduleexploit/unix/webapp/drupal_restws_unserializerank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-03-25
Patch Due Date
2022-04-15
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-02-21
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-3gx6-h57h-rm27

Frequently asked questions

What is CVE-2019-6340?

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Is CVE-2019-6340 actively exploited?

Yes. CVE-2019-6340 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-04-15.

What is the CVSS score for CVE-2019-6340?

CVE-2019-6340 has a CVSS v3 base score of 8.1 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running drupal/core? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record