Skip to main content
Public proof of conceptFix available

CVE-2022-4140

A public proof of concept exists; no exploitation attested.

  • Published2023-01-02
  • Fixed in2.8.5

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file, which could allow unauthenticated attacker to read arbitrary files on the server

Timeline

dates in UTC
  1. 2023-01-0222:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-4140?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-4140?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Welcart welcart e-commerce
BranchAffectedFixed in
2.8< 2.8.52.8.5

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As WPScan, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-01-10

Fix

  1. Update Welcart welcart e-commerce to 2.8.5

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedanirbala98/CVE-2022-4140
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2023-01-02
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-6c75-m6fq-9mh7

Frequently asked questions

What is CVE-2022-4140?

The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file, which could allow unauthenticated attacker to read arbitrary files on the server

Is CVE-2022-4140 actively exploited?

A proof-of-concept exploit exists for CVE-2022-4140, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-4140?

CVE-2022-4140 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record