Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-42475

Exploitation confirmed. First attested on 2022-12-13 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2023-01-02
  • Fixed in7.2.3 · 7.0.9 · 7.0.8 · 6.4.11 · 6.4.10 · 6.2.12
  • WeaknessCWE-197 · CWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11, 6.0.15 and earlier and FortiProxy SSL-VPN 7.2.0 through 7.2.1, 7.0.7 and earlier may allow a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.

Timeline

dates in UTC
  1. 2022-12-13Added to the CISA KEV catalogCISA KEV
  2. 2022-12-13Listed as exploited by GCVEGCVE
  3. 2022-12-13Exploitation first reportedCISA KEV
  4. 2023-01-0209:15CVE publishedNVD
  5. 2024-10-2313:26SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-42475?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-42475?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Fortinet FortiOSversion to verify
BranchAffectedFixed in
7.2≥ 7.2.0, < 7.2.37.2.3
7.0≥ 7.0.0, < 7.0.97.0.9
7.0≥ 7.0.0, < 7.0.87.0.8
6.4≥ 6.4.0, < 6.4.116.4.11
6.4≥ 6.4.0, < 6.4.106.4.10
6.2≥ 6.2.0, < 6.2.126.2.12
6.0≥ 6.0.0, < 6.0.166.0.16
6.0≥ 6.0.0, < 6.0.156.0.15
5.0≥ 5.0.0, ≤ 5.0.14no fix published
5.2≥ 5.2.0, ≤ 5.2.15no fix published
5.4≥ 5.4.0, ≤ 5.4.13no fix published
5.6≥ 5.6.0, ≤ 5.6.14no fix published
Fortinet fortiproxy
BranchAffectedFixed in
7.2≥ 7.2.0, < 7.2.27.2.2
7.0≥ 7.0.0, < 7.0.87.0.8
2.0≥ 2.0.0, < 2.0.122.0.12
1.0≥ 1.0.0, ≤ 1.0.7no fix published
1.1≥ 1.1.0, ≤ 1.1.6no fix published
1.2≥ 1.2.0, ≤ 1.2.13no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA2 products

As fortinet, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Fortinet FortiProxyother versions: not affected
    Affected
    • ≥ 7.2.0, ≤ 7.2.1no fix statedsemver
    • ≥ 7.0.0, ≤ 7.0.7no fix statedsemver
    • ≥ 2.0.0, ≤ 2.0.11no fix statedsemver
    • ≥ 1.2.0, ≤ 1.2.13no fix statedsemver
    • ≥ 1.1.0, ≤ 1.1.6no fix statedsemver
    • ≥ 1.0.0, ≤ 1.0.7no fix statedsemver
  • Fortinet FortiOSother versions: not affected
    Affected
    • ≥ 7.2.0, ≤ 7.2.2no fix statedsemver
    • ≥ 7.0.0, ≤ 7.0.8no fix statedsemver
    • ≥ 6.4.0, ≤ 6.4.10no fix statedsemver
    • ≥ 6.2.0, ≤ 6.2.11no fix statedsemver
    • ≥ 6.0.0, ≤ 6.0.15no fix statedsemver
    • ≥ 5.6.0, ≤ 5.6.14no fix statedsemver
    • ≥ 5.4.0, ≤ 5.4.13no fix statedsemver
    • ≥ 5.2.0, ≤ 5.2.15no fix statedsemver

    1 more version line in the CVE record.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-01-02

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Vendor advisories

  • ICSA-25-044-06 CISA1 known affected

    Siemens RUGGEDCOM APE1808

    RUGGEDCOM APE1808

  • SSA-770770 Siemens ProductCERT1 known affected

    SSA-770770: Multiple Vulnerabilities in Fortigate NGFW Before V7.4.7 on RUGGEDCOM APE1808 Devices

    RUGGEDCOM APE1808

Full record on NVD

Fix

  1. Update Fortinet FortiOS to 7.2.3 · 7.0.9 · 7.0.8 · 6.4.11 · 6.4.10 · 6.2.12 · 6.0.16 · 6.0.15
  2. CISA’s required action: Apply updates per vendor instructions.due 2023-01-03
  3. Vendor fix Siemens ProductCERT SSA-770770 · 1 productUpdate Fortigate NGFW to V7.4.7. Contact customer support to receive patch and update information
  4. Vendor fix CISA ICSA-25-044-06 · 1 productUpdate Fortigate NGFW to V7.4.7. Contact customer support to receive patch and update information
  5. Mitigation from the vendor Siemens ProductCERT SSA-770770 · 1 productRefer to Fortinet Blog for mitigation measures https://www.fortinet.com/blog/psirt-blogs/analysis-of-threat-actor-activity
  6. Mitigation from the vendor CISA ICSA-25-044-06 · 1 productRefer to Fortinet Blog for mitigation measures https://www.fortinet.com/blog/psirt-blogs/analysis-of-threat-actor-activity

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-12-13
Patch Due Date
2023-01-03
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-01-02
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-p3vq-4cxh-gfp9

Frequently asked questions

What is CVE-2022-42475?

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11, 6.0.15 and earlier and FortiProxy SSL-VPN 7.2.0 through 7.2.1, 7.0.7 and earlier may allow a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.

Is CVE-2022-42475 actively exploited?

Yes. CVE-2022-42475 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2023-01-03.

What is the CVSS score for CVE-2022-42475?

CVE-2022-42475 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record