Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2021-25646

Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.

  • Published2021-01-29
  • Fixed in0.20.1

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Apache Druid includes the ability to execute user-provided JavaScript code embedded in various types of requests. This functionality is intended for use in high-trust environments, and is disabled by default. However, in Druid 0.20.0 and earlier, it is possible for an authenticated user to send a specially-crafted request that forces Druid to run user-provided JavaScript code for that request, regardless of server configuration. This can be leveraged to execute code on the target machine with the privileges of the Druid server process.

Timeline

dates in UTC
  1. 2021-01-2920:15CVE publishedNVD
  2. 2023-10-1414:56Listed as exploited by GCVEGCVE
  3. 2023-10-1414:56Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-25646?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-25646?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
druid
BranchAffectedFixed in
0.20< 0.20.10.20.1
Apache druid
BranchAffectedFixed in
0.20≤ 0.20.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Vendor advisories

  • CVE-2021-25646 Red Hat Product Security1 known affected

    druid: Authenticated javascript code injection

    openshift4/ose-metering-hive as a component of Red Hat OpenShift Container Platform 4

Full record on NVD

Fix

  1. Update druid to 0.20.1
  2. No fix planned, says the vendor Red Hat Product Security CVE-2021-25646 · 1 productWill not fix

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/http/apache_druid_js_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2021-01-29
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-wrqf-rrrw-w3mg

Frequently asked questions

What is CVE-2021-25646?

Apache Druid includes the ability to execute user-provided JavaScript code embedded in various types of requests. This functionality is intended for use in high-trust environments, and is disabled by default. However, in Druid 0.20.0 and earlier, it is possible for an authenticated user to send a specially-crafted request that forces Druid to run user-provided JavaScript code for that request, regardless of server configuration. This can be leveraged to execute code on the target machine with the privileges of the Druid server process.

Is CVE-2021-25646 actively exploited?

Active exploitation of CVE-2021-25646 has not been confirmed. Its EPSS score was 99.1% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-25646?

CVE-2021-25646 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running druid? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record