Skip to main content
ExploitedIn CISA KEVFix available

CVE-2021-26084

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2021-08-30
  • Fixed in7.12.5 · 7.11.6 · 7.4.11 · 6.13.23
  • WeaknessCWE-917

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

Timeline

dates in UTC
  1. 2021-08-3007:15CVE publishedNVD
  2. 2021-09-01Exploit-DB entryExploit-DB
  3. 2021-11-03Added to the CISA KEV catalogCISA KEV
  4. 2021-11-03Listed as exploited by GCVEGCVE
  5. 2021-11-03Exploitation first reportedCISA KEV
  6. 2025-12-1618:01SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-26084?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-26084?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Atlassian Confluence
BranchAffectedFixed in
7.12≥ 7.12.0, < 7.12.57.12.5
7.x≥ 7.5.0, < 7.11.67.11.6
7.4≥ 6.14.0, < 7.4.117.4.11
6.13< 6.13.236.13.23
Atlassian Confluence
BranchAffectedFixed in
7.12≥ 7.12.0, < 7.12.57.12.5
7.x≥ 7.5.0, < 7.11.67.11.6
7.4≥ 6.14.0, < 7.4.117.4.11
6.13< 6.13.236.13.23

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA2 products

As atlassian, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Atlassian Confluence Server
    Affected
    • < 6.13.23fixed in 6.13.23custom
    • = 6.14.0no fix statedcustom
    • < 7.4.11fixed in 7.4.11custom
    • = 7.5.0no fix statedcustom
    • < 7.11.6fixed in 7.11.6custom
    • = 7.12.0no fix statedcustom
    • < 7.12.5fixed in 7.12.5custom
  • Atlassian Confluence Data Center
    Affected
    • < 6.13.23fixed in 6.13.23custom
    • = 6.14.0no fix statedcustom
    • < 7.4.11fixed in 7.4.11custom
    • = 7.5.0no fix statedcustom
    • < 7.11.6fixed in 7.11.6custom
    • = 7.12.0no fix statedcustom
    • < 7.12.5fixed in 7.12.5custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-06-08

Fix

  1. Update Atlassian Confluence to 7.12.5 · 7.11.6 · 7.4.11 · 6.13.23
  2. CISA’s required action: Apply updates per vendor instructions.due 2021-11-17

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-50243
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/atlassian_confluence_webwork_ognl_injectionrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2021-11-17
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-08-30
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-855c-xp53-5fp2

Frequently asked questions

What is CVE-2021-26084?

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

Is CVE-2021-26084 actively exploited?

Yes. CVE-2021-26084 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2021-11-17.

What is the CVSS score for CVE-2021-26084?

CVE-2021-26084 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record