Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2021-21307

Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.

  • Published2021-02-11
  • Fixed in5.3.7.47 · 5.3.6.68 · 5.3.5.96
  • WeaknessCWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

Timeline

dates in UTC
  1. 2021-02-1119:15CVE publishedNVD
  2. 2023-10-1414:57Listed as exploited by GCVEGCVE
  3. 2023-10-1414:57Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-21307?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-21307?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Lucee lucee server
BranchAffectedFixed in
5.3≥ 5.3.7.00, < 5.3.7.475.3.7.47
5.3≥ 5.3.6.00, < 5.3.6.685.3.6.68
5.3≥ 5.3.5.00, < 5.3.5.965.3.5.96

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Lucee lucee server to 5.3.7.47 · 5.3.6.68 · 5.3.5.96

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/linux/http/lucee_admin_imgprocess_file_writerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-02-11
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-21307?

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

Is CVE-2021-21307 actively exploited?

Active exploitation of CVE-2021-21307 has not been confirmed. Its EPSS score was 89.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-21307?

CVE-2021-21307 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record