Skip to main content
Public proof of conceptFix available

CVE-2020-5504

A public proof of concept exists; no exploitation attested.

  • Published2020-01-09
  • Fixed in5.0.1 · 4.9.4
  • WeaknessCWE-89

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Timeline

dates in UTC
  1. 2020-01-0922:15CVE publishedNVD
  2. 2025-12-03Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-5504?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-5504?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Phpmyadmin
BranchAffectedFixed in
5.0≥ 5.0.0, < 5.0.15.0.1
4.x≥ 4.0.0, < 4.9.44.9.4
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
Suse suse linux enterprise server
BranchAffectedFixed in
12.x= 12no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • phpmyadminUbuntu:Pro:20.04:LTSall versions · fixed in 4:4.9.5+dfsg1-2ubuntu0.1~esm1
  • phpmyadminUbuntu:Pro:18.04:LTSall versions · fixed in 4:4.6.6-5ubuntu0.5+esm1
  • phpmyadminUbuntu:Pro:16.04:LTSall versions · fixed in 4:4.5.4.1-2ubuntu2.1+esm6
  • phpmyadminUbuntu:Pro:14.04:LTSall versions · fixed in 4:4.0.10-1ubuntu0.1+esm4
  • phpmyadminUbuntu:26.10all versions · no fixed version listed
  • phpmyadminUbuntu:26.04:LTSall versions · no fixed version listed
  • phpmyadminUbuntu:25.10all versions · no fixed version listed
  • phpmyadminUbuntu:24.04:LTSall versions · no fixed version listed

27 more package ranges on OSV.dev

Vendor advisories

  • CVE-2020-5504 Red Hat Product Security

    phpmyadmin: SQL injection in the user accounts page

Full record on NVD

Fix

  1. Update Phpmyadmin to 5.0.1 · 4.9.4

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-52451
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedxMohamed0/CVE-2020-5504-phpMyAdminCerberusMrXi/phpMyAdmin-CVE-2020-5504-Exploit
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2020-01-09
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-fgj8-93xx-f6g6

Frequently asked questions

What is CVE-2020-5504?

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Is CVE-2020-5504 actively exploited?

Active exploitation of CVE-2020-5504 has not been confirmed. Its EPSS score was 28.0% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-5504?

CVE-2020-5504 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running phpmyadmin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record