Skip to main content
Public proof of conceptFix available

CVE-2020-26935

A public proof of concept exists; no exploitation attested.

  • Published2020-10-10
  • Fixed in5.0.3 · 4.9.6
  • WeaknessCWE-89

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

Timeline

dates in UTC
  1. 2020-10-1019:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-26935?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-26935?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Phpmyadmin
BranchAffectedFixed in
5.0≥ 5.0.0, < 5.0.35.0.3
4.9≥ 4.9.0, < 4.9.64.9.6
Fedoraproject fedora
BranchAffectedFixed in
31.x= 31no fix published
32.x= 32no fix published
33.x= 33no fix published
Opensuse leap
BranchAffectedFixed in
15.1= 15.1no fix published
15.2= 15.2no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • phpmyadminUbuntu:Pro:20.04:LTSall versions · fixed in 4:4.9.5+dfsg1-2ubuntu0.1~esm1
  • phpmyadminUbuntu:Pro:18.04:LTSall versions · fixed in 4:4.6.6-5ubuntu0.5+esm1
  • phpmyadminUbuntu:Pro:16.04:LTSall versions · fixed in 4:4.5.4.1-2ubuntu2.1+esm6
  • phpmyadminUbuntu:Pro:14.04:LTSall versions · fixed in 4:4.0.10-1ubuntu0.1+esm4
  • phpmyadminUbuntu:18.04:LTSall versions · fixed in 4:4.6.6-5ubuntu0.5
  • phpmyadminMageia:7all versions · fixed in 4.9.6-1.mga7
  • phpmyadminDebian:14all versions · fixed in 4:4.9.7+dfsg1-1
  • phpmyadminDebian:13all versions · fixed in 4:4.9.7+dfsg1-1

12 more package ranges on OSV.dev

Vendor advisories

  • CVE-2020-26935 Red Hat Product Security

    phpmyadmin: SQL injection vulnerability in SearchController

Full record on NVD

Fix

  1. Update Phpmyadmin to 5.0.3 · 4.9.6

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2020-10-10
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-7ff4-cv53-4cjq

Frequently asked questions

What is CVE-2020-26935?

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

Is CVE-2020-26935 actively exploited?

Active exploitation of CVE-2020-26935 has not been confirmed. Its EPSS score was 63.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-26935?

CVE-2020-26935 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running phpmyadmin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record