Skip to main content
Public proof of conceptFix available

CVE-2018-12613

A public proof of concept exists; no exploitation attested.

  • Published2018-06-21
  • Fixed in4.8.2
  • WeaknessCWE-287

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

Timeline

dates in UTC
  1. 2018-06-21Exploit-DB entryExploit-DB
  2. 2018-06-2120:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-12613?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-12613?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Phpmyadmin
BranchAffectedFixed in
4.8≥ 4.8.0, < 4.8.24.8.2
4.8≥ 4.8, < 4.8.24.8.2

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • phpmyadminCleanStartall versions · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.24from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.23from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.22from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.21from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.20from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.19from 4.8.0 · fixed in 4.8.2-r0
  • phpmyadminAlpine:v3.18from 4.8.0 · fixed in 4.8.2-r0

11 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-12613 Red Hat Product Security

    phpMyAdmin: Multiple security issues fixed in 4.8.4

Full record on NVD

Fix

  1. Update Phpmyadmin to 4.8.2

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Metasploit modules
1 moduleexploit/multi/http/phpmyadmin_lfi_rcerank: goodModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2018-06-21
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-x394-g9j8-x7mf

Frequently asked questions

What is CVE-2018-12613?

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

Is CVE-2018-12613 actively exploited?

Active exploitation of CVE-2018-12613 has not been confirmed. Its EPSS score was 98.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-12613?

CVE-2018-12613 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running phpmyadmin/phpmyadmin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record