Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-3396

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-03-25
  • Fixed in6.14.2 · 6.13.3 · 6.12.3 · 6.6.12
  • WeaknessCWE-22

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Timeline

dates in UTC
  1. 2019-03-2519:29CVE publishedNVD
  2. 2019-04-19Exploit-DB entryExploit-DB
  3. 2021-11-03Added to the CISA KEV catalogCISA KEV
  4. 2021-11-03Listed as exploited by GCVEGCVE
  5. 2021-11-03Exploitation first reportedCISA KEV
  6. 2025-02-0712:25SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-3396?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-3396?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Atlassian Confluence
BranchAffectedFixed in
6.14≥ 6.14.0, < 6.14.26.14.2
6.13≥ 6.13.0, < 6.13.36.13.3
6.x≥ 6.7.0, < 6.12.36.12.3
6.6< 6.6.126.6.12

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As atlassian, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Atlassian Confluence Server
    Affected
    • < 6.6.12fixed in 6.6.12custom
    • = 6.7.0no fix statedcustom
    • < 6.12.3fixed in 6.12.3custom
    • = next of 6.13.0no fix statedcustom
    • < 6.13.3fixed in 6.13.3custom
    • = next of 6.14.0no fix statedcustom
    • < 6.14.2fixed in 6.14.2custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-01-22

Fix

  1. Update Atlassian Confluence to 6.14.2 · 6.13.3 · 6.12.3 · 6.6.12
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-46731EDB-49465
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/confluence_widget_connectorrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-03-25
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-fr34-8fhg-2m6q

Frequently asked questions

What is CVE-2019-3396?

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Is CVE-2019-3396 actively exploited?

Yes. CVE-2019-3396 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2019-3396?

CVE-2019-3396 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record