Skip to main content
Public proof of conceptFix available

CVE-2019-5420

A public proof of concept exists; no exploitation attested.

  • Published2019-03-27
  • Fixed in5.2.2.1
  • WeaknessCWE-330 · CWE-77

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A remote code execution vulnerability in development mode Rails <5.2.2.1, <6.0.0.beta3 can allow an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit.

Timeline

dates in UTC
  1. 2019-03-2714:29CVE publishedNVD
  2. 2019-05-02Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-5420?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-5420?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Ruby on Rails
BranchAffectedFixed in
5.2< 5.2.2.15.2.2.1
5.2≥ 5.2.0, < 5.2.2.15.2.2.1
6.0= 6.0.0no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
Fedoraproject fedora
BranchAffectedFixed in
30.x= 30no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • railsDebian:14all versions · fixed in 2:5.2.2.1+dfsg-1
  • railsDebian:13all versions · fixed in 2:5.2.2.1+dfsg-1
  • railsDebian:12all versions · fixed in 2:5.2.2.1+dfsg-1
  • rmt-serverSUSE:Linux Enterprise Server for SAP Applications 15all versions · fixed in 2.6.5-3.34.1
  • rmt-serverSUSE:Linux Enterprise Server 15-LTSSall versions · fixed in 2.6.5-3.34.1
  • rmt-serverSUSE:Linux Enterprise Module for Server Applications 15 SP2all versions · fixed in 2.6.5-3.3.1
  • rmt-serverSUSE:Linux Enterprise Module for Server Applications 15 SP1all versions · fixed in 2.6.5-3.18.1
  • rmt-serverSUSE:Linux Enterprise Module for Public Cloud 15 SP2all versions · fixed in 2.6.5-3.3.1

6 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-5420 Red Hat Product Security

    rubygem-rails: Weak secret token leading to possible code execution

Full record on NVD

Fix

  1. Update Ruby on Rails to 5.2.2.1

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-46785
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/rails_double_taprank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-03-27
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-m42h-mh85-4qgc

Frequently asked questions

What is CVE-2019-5420?

A remote code execution vulnerability in development mode Rails <5.2.2.1, <6.0.0.beta3 can allow an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit.

Is CVE-2019-5420 actively exploited?

Active exploitation of CVE-2019-5420 has not been confirmed. Its EPSS score was 89.3% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-5420?

CVE-2019-5420 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running rubygem-rails? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record