Skip to main content
Public proof of conceptFix available

CVE-2018-17456

A public proof of concept exists; no exploitation attested.

  • Published2018-10-06
  • WeaknessCWE-88

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive "git clone" of a superproject if a .gitmodules file has a URL field beginning with a '-' character.

Timeline

dates in UTC
  1. 2018-10-05Exploit-DB entryExploit-DB
  2. 2018-10-0614:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-17456?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-17456?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Redhat enterprise linux
BranchAffectedFixed in
6.0= 6.0no fix published
6.7= 6.7no fix published
7.0= 7.0no fix published
7.3= 7.3no fix published
7.4= 7.4no fix published
7.5= 7.5no fix published
7.6= 7.6no fix published
Git-scm git
BranchAffectedFixed in
2.19≥ 2.19.0, < 2.19.12.19.1
2.18≥ 2.18.0, < 2.18.12.18.1
2.17≥ 2.17.0, < 2.17.22.17.2
2.16≥ 2.16.0, < 2.16.52.16.5
2.15≥ 2.15.0, < 2.15.32.15.3
2.14≥ 2.14.0, < 2.14.52.14.5
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published

8 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gitUbuntu:18.04:LTSall versions · fixed in 1:2.17.1-1ubuntu0.3
  • gitUbuntu:16.04:LTSall versions · fixed in 1:2.7.4-0ubuntu1.5
  • gitUbuntu:14.04:LTSall versions · fixed in 1:1.9.1-1ubuntu0.9
  • gitSUSE:OpenStack Cloud 8all versions · fixed in 2.12.3-27.17.2
  • gitSUSE:OpenStack Cloud 7all versions · fixed in 2.12.3-27.17.2
  • gitSUSE:Linux Enterprise Software Development Kit 12 SP4all versions · fixed in 2.12.3-27.17.2
  • gitSUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 2.12.3-27.17.2
  • gitSUSE:Linux Enterprise Server for SAP Applications 12 SP4all versions · fixed in 2.12.3-27.17.2

56 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-17456 Red Hat Product Security426 products fixed · 3 known affected

    git: arbitrary code execution via .gitmodules

    camel as a component of Red Hat Fuse 7 · camel as a component of Red Hat JBoss Fuse 6 · camel as a component of Red Hat JBoss Fuse Integration Service 2

  • RHSA-2020:0316 Red Hat Product Security77 products fixed

    Red Hat Security Advisory: git security update

  • RHSA-2018:3541 Red Hat Product Security216 products fixed

    Red Hat Security Advisory: rh-git29-git security update

  • RHSA-2018:3408 Red Hat Product Security133 products fixed

    Red Hat Security Advisory: git security update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2020:0316 · 77 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. No fix available, says the vendor Red Hat Product Security CVE-2018-17456 · 3 productsAffected

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-45548EDB-45631
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/git_submodule_url_execrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2018-10-06
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-17456?

Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive "git clone" of a superproject if a .gitmodules file has a URL field beginning with a '-' character.

Is CVE-2018-17456 actively exploited?

Active exploitation of CVE-2018-17456 has not been confirmed. Its EPSS score was 97.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-17456?

CVE-2018-17456 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running git? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record