Skip to main content
Public proof of conceptFix available

CVE-2014-9390

A public proof of concept exists; no exploitation attested.

  • Published2020-02-12
  • Fixed in3.2.3
  • WeaknessCWE-20

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

Timeline

dates in UTC
  1. 2020-02-1202:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2014-9390?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2014-9390?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Mercurialversion to verify
BranchAffectedFixed in
3.2< 3.2.33.2.3
Git-scm gitversion to verify
BranchAffectedFixed in
2.2≥ 2.2.0, < 2.2.12.2.1
2.1≥ 2.1.0, < 2.1.42.1.4
2.0≥ 2.0.0, < 2.0.52.0.5
1.9≥ 1.9.0, < 1.9.51.9.5
1.8< 1.8.5.61.8.5.6
Eclipse jgit
BranchAffectedFixed in
3.5≥ 3.5.0, < 3.5.33.5.3
3.5< 3.5.33.5.3
3.4< 3.4.23.4.2

3 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • cgitMageia:5all versions · fixed in 0.11.2-1.mga5
  • cgitMageia:4all versions · fixed in 0.11.2-1.mga4
  • dulwichDebian:14all versions · fixed in 0.10.1-1
  • dulwichDebian:13all versions · fixed in 0.10.1-1
  • dulwichDebian:12all versions · fixed in 0.10.1-1
  • gitUbuntu:14.04:LTSall versions · fixed in 1:1.9.1-1ubuntu0.1
  • gitopenSUSE:Tumbleweedall versions · fixed in 2.11.0-1.1
  • gitMageia:4all versions · fixed in 1.8.5.6-1.mga4

15 more package ranges on OSV.dev

Vendor advisories

  • CVE-2014-9390 Red Hat Product Security

    git: arbitrary command execution vulnerability on case-insensitive file systems

Full record on NVD

Fix

  1. Update Mercurial to 3.2.3

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/git_client_command_execrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2020-02-12
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-6vvc-c2m3-cjf3

Frequently asked questions

What is CVE-2014-9390?

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

Is CVE-2014-9390 actively exploited?

Active exploitation of CVE-2014-9390 has not been confirmed. Its EPSS score was 75.6% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2014-9390?

CVE-2014-9390 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running mercurial? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record