Skip to main content
Public proof of conceptFix available

CVE-2018-11235

A public proof of concept exists; no exploitation attested.

  • Published2018-05-30
  • WeaknessCWE-22

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs "git clone --recurse-submodules" because submodule "names" are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with "../" in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server.

Timeline

dates in UTC
  1. 2018-05-3004:29CVE publishedNVD

Versions per branch

NVD
Git-scm git
BranchAffectedFixed in
2.13≤ 2.13.6no fix published
2.14≥ 2.14.0, ≤ 2.14.3no fix published
2.15≥ 2.15.0, ≤ 2.15.1no fix published
2.16≥ 2.16.0, ≤ 2.16.3no fix published
2.17= 2.17.0no fix published
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
17.10= 17.10no fix published
18.4= 18.04no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
9.0= 9.0no fix published

6 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gitUbuntu:18.04:LTSall versions · fixed in 1:2.17.1-1ubuntu0.1
  • gitUbuntu:16.04:LTSall versions · fixed in 1:2.7.4-0ubuntu1.4
  • gitUbuntu:14.04:LTSall versions · fixed in 1:1.9.1-1ubuntu0.8
  • gitSUSE:OpenStack Cloud 8all versions · fixed in 2.12.3-27.14.1
  • gitSUSE:OpenStack Cloud 7all versions · fixed in 2.12.3-27.14.1
  • gitSUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 2.12.3-27.14.1
  • gitSUSE:Linux Enterprise Server for SAP Applications 12 SP3all versions · fixed in 2.12.3-27.14.1
  • gitSUSE:Linux Enterprise Server for SAP Applications 12 SP2all versions · fixed in 2.12.3-27.14.1

52 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-11235 Red Hat Product Security252 products fixed · 7 known affected

    git: arbitrary code execution when recursively cloning a malicious repository

    jgit as a component of JBoss Developer Studio 11 · source-to-image.src as a component of Red Hat OpenShift Container Platform 3.2 · source-to-image.src as a component of Red Hat OpenShift Container Platform 3.3 · +4 more

  • RHSA-2018:2147 Red Hat Product Security134 products fixed

    Red Hat Security Advisory: rh-git29-git security update

  • RHSA-2018:1957 Red Hat Product Security118 products fixed

    Red Hat Security Advisory: git security update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2018:2147 · 134 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. Workaround from the vendor Red Hat Product Security RHSA-2018:2147 · 134 productsDon't create OCP source-to-image applications from source code repositories hosted by untrusted parties. Github is blocking users from pushing repositories with malicious submodules so it's less likely you can pull a malicious repository from there which triggers this vulnerability.
  3. No fix planned, says the vendor Red Hat Product Security CVE-2018-11235 · 7 productsWill not fix

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.07.8read 2026-10-23
  • NVDCVSS 2.06.8read 2026-10-23
  • NVDweakness (CWE)CWE-22read 2026-10-23
  • FIRST EPSSEPSS score48.1 %read 2026-11-04
  • PoC-in-GitHubproof of concept15known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2018-05-30
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-11235?

In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs "git clone --recurse-submodules" because submodule "names" are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with "../" in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server.

Is CVE-2018-11235 actively exploited?

Active exploitation of CVE-2018-11235 has not been confirmed. Its EPSS score was 48.1% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-11235?

CVE-2018-11235 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running git? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record