Skip to main content
Public proof of conceptFix available

CVE-2018-10933

A public proof of concept exists; no exploitation attested.

  • Published2018-10-17
  • Fixed in0.8.4 · 0.7.6
  • WeaknessCWE-287 · CWE-592

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A vulnerability was found in libssh's server-side state machine before versions 0.7.6 and 0.8.4. A malicious client could create channels without first performing authentication, resulting in unauthorized access.

Timeline

dates in UTC
  1. 2018-10-1712:29CVE publishedNVD
  2. 2018-10-18Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-10933?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-10933?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Libssh
BranchAffectedFixed in
0.8≥ 0.8.0, < 0.8.40.8.4
0.x≥ 0.6.0, < 0.7.60.7.6
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
18.10= 18.10no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
9.0= 9.0no fix published

6 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • cockpitRed Hat:rhel_extras_other:7all versions · fixed in 0:176-4.el7and 6 other packages
  • libsshUbuntu:18.04:LTSall versions · fixed in 0.8.0~20170825.94fa1e38-1ubuntu0.1
  • libsshUbuntu:16.04:LTSall versions · fixed in 0.6.3-4.3ubuntu0.1
  • libsshUbuntu:14.04:LTSall versions · fixed in 0.6.1-0ubuntu3.4
  • libsshSUSE:Linux Enterprise Workstation Extension 12 SP3all versions · fixed in 0.6.3-12.6.1
  • libsshSUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 0.6.3-12.6.1
  • libsshSUSE:Linux Enterprise Module for Basesystem 15all versions · fixed in 0.7.5-6.3.1
  • libsshSUSE:Linux Enterprise Desktop 12 SP3all versions · fixed in 0.6.3-12.6.1

29 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-10933 Red Hat Product Security35 products fixed

    libssh: Authentication Bypass due to improper message callbacks implementation

  • ICSA-21-007-01 CISA2 known affected

    Hitachi ABB Power Grids FOX615 Multiservice-Multiplexer

    FOX61x R2 using CESM1/CESM2: All versions prior to cesne_r2d14_03.esw · FOX61x R1 using CESM1/CESM2: All versions prior to cesne_r1h07_12.esw

  • ICSA-20-294-02 CISA2 known affected

    Hitachi ABB Power Grids XMC20 Multiservice-Multiplexer

    XMC20 R6 using COGE5: versions older than co5ne_r2d14_03.esw · XMC20 R4 using COGE5: versions older than co5ne_r1h07_12.esw

  • RHBA-2018:3712 Red Hat Product Security35 products fixed

    Red Hat Bug Fix Advisory: cockpit bug fix update

Full record on NVD

Fix

  1. Update Libssh to 0.8.4 · 0.7.6
  2. Vendor fix Red Hat Product Security RHBA-2018:3712 · 53 productsBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/articles/11258
  3. Mitigation from the vendor CISA ICSA-21-007-01 · 2 productsHitachi ABB Power Grids recommends users apply the following firmware: FOX61x R1: CESM1/CESM2: Update to Version cesne_r1h07_12.esw or newer
  4. Mitigation from the vendor CISA ICSA-21-007-01 · 2 productsHitachi ABB Power Grids recommends users apply the following firmware: FOX61x R2: CESM1/CESM2: Update to Version cesne_r2d14_03.esw or newer
  5. Mitigation from the vendor CISA ICSA-21-007-01 · 2 productsFor additional information and support please contact a product provider or Hitachi ABB Power Grids service organization.
  6. Mitigation from the vendor CISA ICSA-21-007-01 · 2 productsHitachi ABB Power Grids recommends security practices and firewall configurations to help protect a process control network from attacks originating from outside the network. Such practices require process control systems be physically protected from direct access by unauthorized personnel, have no…
  7. Mitigation from the vendor CISA ICSA-20-294-02 · 2 productsHitachi ABB Power Grids has corrected the problem in the following product versions and recommends users apply the firmware update at the earliest availability

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-45638EDB-46307
Exploit-DB
Metasploit modules
1 moduleauxiliary/scanner/ssh/libssh_auth_bypassrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • CNACVSS 3.09.1known since 2026-10-23
  • NVDCVSS 3.09.1read 2026-10-23
  • NVDCVSS 2.06.4read 2026-10-23
  • CNAweakness (CWE)CWE-592known since 2026-10-23
  • NVDweakness (CWE)CWE-287read 2026-10-23
  • FIRST EPSSEPSS score91.8 %read 2026-11-02
  • PoC-in-GitHubproof of concept20read 2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Published
2018-10-17
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-10933?

A vulnerability was found in libssh's server-side state machine before versions 0.7.6 and 0.8.4. A malicious client could create channels without first performing authentication, resulting in unauthorized access.

Is CVE-2018-10933 actively exploited?

Active exploitation of CVE-2018-10933 has not been confirmed. Its EPSS score was 91.8% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-10933?

CVE-2018-10933 has a CVSS v3 base score of 9.1 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.

Running libssh? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record