Skip to main content
No exploitation reportedFix available

CVE-2020-1730

No exploitation reported by the sources we read.

  • Published2020-04-13
  • Fixed in0.9.4 · 0.8.9
  • WeaknessCWE-476

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A flaw was found in libssh versions before 0.8.9 and before 0.9.4 in the way it handled AES-CTR (or DES ciphers if enabled) ciphers. The server or client could crash when the connection hasn't been fully initialized and the system tries to cleanup the ciphers when closing the connection. The biggest threat from this vulnerability is system availability.

Timeline

dates in UTC
  1. 2020-04-1319:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-02 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-1730?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-1730?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Libssh
BranchAffectedFixed in
0.9≥ 0.9.0, < 0.9.40.9.4
0.8≥ 0.8.0, < 0.8.90.8.9
Canonical ubuntu linux
BranchAffectedFixed in
18.4= 18.04no fix published
19.10= 19.10no fix published
Fedoraproject fedora
BranchAffectedFixed in
31.x= 31no fix published
32.x= 32no fix published

3 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libsshUbuntu:18.04:LTSall versions · fixed in 0.8.0~20170825.94fa1e38-1ubuntu0.6
  • libsshSUSE:Linux Enterprise Software Development Kit 12 SP5all versions · fixed in 0.8.7-3.9.1
  • libsshSUSE:Linux Enterprise Software Development Kit 12 SP5all versions · fixed in 0.9.8-3.12.2
  • libsshSUSE:Linux Enterprise Server for SAP Applications 15 SP3all versions · fixed in 0.9.8-150200.13.3.1
  • libsshSUSE:Linux Enterprise Server for SAP Applications 15 SP2all versions · fixed in 0.9.8-150200.13.3.1
  • libsshSUSE:Linux Enterprise Server for SAP Applications 12 SP5all versions · fixed in 0.8.7-3.9.1
  • libsshSUSE:Linux Enterprise Server for SAP Applications 12 SP5all versions · fixed in 0.9.8-3.12.2
  • libsshSUSE:Linux Enterprise Server 15 SP3-LTSSall versions · fixed in 0.9.8-150200.13.3.1

23 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Libssh to 0.9.4 · 0.8.9

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.15.3known since 2026-10-23
  • NVDCVSS 3.15.3read 2026-10-23
  • NVDCVSS 2.05read 2026-10-23
  • CNAweakness (CWE)CWE-476known since 2026-10-23
  • NVDweakness (CWE)CWE-476read 2026-10-23
  • FIRST EPSSEPSS score3.1 %2026-11-02
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Published
2020-04-13
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2020-1730?

A flaw was found in libssh versions before 0.8.9 and before 0.9.4 in the way it handled AES-CTR (or DES ciphers if enabled) ciphers. The server or client could crash when the connection hasn't been fully initialized and the system tries to cleanup the ciphers when closing the connection. The biggest threat from this vulnerability is system availability.

Is CVE-2020-1730 actively exploited?

Active exploitation of CVE-2020-1730 has not been confirmed. Its EPSS score was 3.1% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-1730?

CVE-2020-1730 has a CVSS v3 base score of 5.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L.

Running libssh? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record