Skip to main content
No exploitation reportedFix available

CVE-2016-0739

No exploitation reported by the sources we read.

  • Published2016-04-13
  • WeaknessCWE-200

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

libssh before 0.7.3 improperly truncates ephemeral secrets generated for the (1) diffie-hellman-group1 and (2) diffie-hellman-group14 key exchange methods to 128 bits, which makes it easier for man-in-the-middle attackers to decrypt or intercept SSH sessions via unspecified vectors, aka a "bits/bytes confusion bug."

Timeline

dates in UTC
  1. 2016-04-1317:59CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-0739?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-0739?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Libssh
BranchAffectedFixed in
0.7≤ 0.7.2no fix published
Canonical ubuntu linux
BranchAffectedFixed in
12.4= 12.04no fix published
14.4= 14.04no fix published
15.10= 15.10no fix published
Debian debian linux
BranchAffectedFixed in
7.0= 7.0no fix published
8.0= 8.0no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libsshUbuntu:16.04:LTSall versions · fixed in 0.6.3-4.2ubuntu1
  • libsshUbuntu:14.04:LTSall versions · fixed in 0.6.1-0ubuntu3.3
  • libsshSUSE:Linux Enterprise Workstation Extension 12 SP1all versions · fixed in 0.6.3-11.1
  • libsshSUSE:Linux Enterprise Workstation Extension 12all versions · fixed in 0.6.3-11.1
  • libsshSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 0.6.3-11.1
  • libsshSUSE:Linux Enterprise Software Development Kit 12all versions · fixed in 0.6.3-11.1
  • libsshSUSE:Linux Enterprise Software Development Kit 11 SP4all versions · fixed in 0.2-5.22.1
  • libsshSUSE:Linux Enterprise Desktop 12 SP1all versions · fixed in 0.6.3-11.1

10 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.05.9read 2026-10-23
  • NVDCVSS 2.04.3read 2026-10-23
  • NVDweakness (CWE)CWE-200read 2026-10-23
  • FIRST EPSSEPSS score2.4 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2016-04-13
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2016-0739?

libssh before 0.7.3 improperly truncates ephemeral secrets generated for the (1) diffie-hellman-group1 and (2) diffie-hellman-group14 key exchange methods to 128 bits, which makes it easier for man-in-the-middle attackers to decrypt or intercept SSH sessions via unspecified vectors, aka a "bits/bytes confusion bug."

Is CVE-2016-0739 actively exploited?

Active exploitation of CVE-2016-0739 has not been confirmed. Its EPSS score was 2.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-0739?

CVE-2016-0739 has a CVSS v3 base score of 5.9 (MEDIUM severity), with vector string CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N.

Running libssh? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record