Skip to main content
No exploitation reportedFix availableAwaiting NVD analysis

CVE-2026-115825

HTTP::Server::PSGI versions before 1.0056 for Perl allow a single request to crash the server by declaring a large Content-Length

No exploitation reported by the sources we read.

  • Published2026-10-25
  • WeaknessCWE-789

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

HTTP::Server::PSGI versions before 1.0056 for Perl allow a single request to crash the server by declaring a large Content-Length. The request body is read with sysread() calls sized by the remaining Content-Length. Perl grows the read buffer to the requested length before any data arrives, so the server tries to allocate as much memory as the client declares. A remote attacker can send one request with a large Content-Length and a few body bytes, and perl exits with an out-of-memory error before the application is called. HTTP::Server::PSGI runs as a single process, so the server stays down until restarted.

Timeline

dates in UTC
  1. 2026-10-2516:51CVE publishedCNA

Observed activity

isMalicious corpus · updated 2026-11-02 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2026-115825?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2026-115825?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

Products declared by the CNA1 product

As CPANSec, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-10-25

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libplack-perlDebian:14all versions · fixed in 1.0057-1
  • libplack-perlDebian:13all versions · no fixed version listed
  • libplack-perlDebian:12all versions · no fixed version listed
  • perl-PlackopenSUSE:Tumbleweedall versions · fixed in 1.0057-1.1

Vendor advisories

  • CVE-2026-115825 Red Hat Product Security

    perl-Plack: perl-Plack: Denial of Service via large Content-Length header

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2026-10-25
Last Modified
2026-11-02
NVD status
Awaiting Analysis
GitHub Advisory
GHSA-jmh5-fmfv-h6f8

Frequently asked questions

What is CVE-2026-115825?

HTTP::Server::PSGI versions before 1.0056 for Perl allow a single request to crash the server by declaring a large Content-Length. The request body is read with sysread() calls sized by the remaining Content-Length. Perl grows the read buffer to the requested length before any data arrives, so the server tries to allocate as much memory as the client declares. A remote attacker can send one request with a large Content-Length and a few body bytes, and perl exits with an out-of-memory error before the application is called. HTTP::Server::PSGI runs as a single process, so the server stays down until restarted.

Is CVE-2026-115825 actively exploited?

Active exploitation of CVE-2026-115825 has not been confirmed. Its EPSS score was 0.3% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2026-115825?

CVE-2026-115825 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running perl-Plack? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record