Skip to main content
Public proof of conceptFix available

CVE-2025-68973

A public proof of concept exists; no exploitation attested.

  • Published2025-12-28
  • WeaknessCWE-675 · CWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In GnuPG before 2.4.9, armor_filter in g10/armor.c has two increments of an index variable where one is intended, leading to an out-of-bounds write for crafted input. (For ExtendedLTS, 2.2.51 and later are fixed versions.)

Timeline

dates in UTC
  1. 2025-12-2817:16CVE publishedNVD

Versions per branch

NVD
Gnupg
BranchAffectedFixed in
2.4≤ 2.4.8no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As mitre, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • GnuPGother versions: unknown
    Affected
    • < 2.2.51fixed in 2.2.51semver
    • ≥ 2.3.0, < 2.4.9fixed in 2.4.9semver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-01-02

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gnupgUbuntu:Pro:16.04:LTSall versions · fixed in 1.4.20-1ubuntu3.3+esm3
  • gnupgUbuntu:Pro:14.04:LTSall versions · fixed in 1.4.16-1ubuntu2.6+esm2
  • gnupgTuxCare:Ubuntu:16.04all versions · fixed in 1.4.20-1ubuntu3.3+tuxcare.els2and 2 other packages
  • gnupgRoot:Alpine:3.19all versions · fixed in 2.4.4-r00071and 1 other package
  • gnupgRoot:Alpine:3.19all versions · fixed in 2.4.4-r00072and 1 other package
  • gnupgMinimOSall versions · fixed in 2.4.9-r0and 12 other packages
  • gnupgAlpine:v3.24all versions · fixed in 2.4.9-r0
  • gnupgAlpine:v3.23all versions · fixed in 2.4.9-r0

98 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2026:2568 Red Hat Product Security36 products fixed

    Red Hat Security Advisory: RHACS 4.9.3 security and bug fix update

  • RHSA-2026:2563 Red Hat Product Security4 products fixed

    Red Hat Security Advisory: Red Hat Update Infrastructure 5 security update

  • RHSA-2026:2485 Red Hat Product Security2 products fixed

    Red Hat Security Advisory: Insights proxy Container Image

  • RHSA-2026:2350 Red Hat Product Security36 products fixed

    Red Hat Security Advisory: RHACS 4.9.3 security and bug fix update

  • RHSA-2026:1736 Red Hat Product Security4 products fixed

    Red Hat Security Advisory: A Subscription Management tool for finding and reporting Red Hat product usage

  • RHSA-2026:1652 Red Hat Product Security4 products fixed

    Red Hat Security Advisory: Red Hat Ceph Storage

1 more advisory

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2026:2568 · 36 productsIf you are using an earlier version of RHACS, you are advised to upgrade to the version of RHACS mentioned in the synopsis and release notes in order to take advantage of the enhancements, bug fixes, and/or security patches in the release.
  2. Vendor fix Red Hat Product Security RHSA-2026:2563 · 4 productsThe container images provided by this release, apart from the installer, should be deployed using rhui-installer utility. See the official documentation for more details.
  3. Vendor fix Red Hat Product Security RHSA-2026:2485 · 2 productsThe Insights proxy container image provided here is downloaded by the Red Hat Insights proxy product RPM. Before applying this update, make sure all previously released errata relevant to your system have been applied.
  4. Vendor fix Red Hat Product Security RHSA-2026:1736 · 4 productsThe containers required to run Discovery can be installed through discovery-installer RPM. See the official documentation for more details.
  5. Vendor fix Red Hat Product Security RHSA-2026:1652 · 4 productsThe container images provided by this update can be downloaded from the Red Hat container registry at registry.redhat.io using the "podman pull" command.
  6. Workaround from the vendor Red Hat Product Security RHSA-2026:2568 · 45 productsTo mitigate this issue, users should avoid processing untrusted or unverified input with GnuPG. Exercise caution when handling GnuPG-encrypted or signed data from unknown or suspicious sources, as specially crafted input could trigger the vulnerability. This operational control reduces the attack s…

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionpoc2026-04-29
  • CNACVSS 3.17.8known since 2026-10-23
  • NVDCVSS 3.17read 2026-10-23
  • CNAweakness (CWE)CWE-675known since 2026-10-23
  • NVDweakness (CWE)CWE-787read 2026-10-23
  • FIRST EPSSEPSS score0.2 %2026-11-04
  • OSVaffected packages—
  • GitHub Advisoriesadvisory—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2025-12-28
Last Modified
2026-10-13
NVD status
Modified
GitHub Advisory
GHSA-pj23-86ww-f72p

Frequently asked questions

What is CVE-2025-68973?

In GnuPG before 2.4.9, armor_filter in g10/armor.c has two increments of an index variable where one is intended, leading to an out-of-bounds write for crafted input. (For ExtendedLTS, 2.2.51 and later are fixed versions.)

Is CVE-2025-68973 actively exploited?

A proof-of-concept exploit exists for CVE-2025-68973, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2025-68973?

CVE-2025-68973 has a CVSS v3 base score of 7 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running RHACS 4.9.3? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record