Skip to main content
No exploitation reportedFix available

CVE-2025-30258

No exploitation reported by the sources we read.

  • Published2025-03-19
  • Fixed in2.5.5 · 2.4.8
  • WeaknessCWE-754

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In GnuPG before 2.5.5, if a user chooses to import a certificate with certain crafted subkey data that lacks a valid backsig or that has incorrect usage flags, the user loses the ability to verify signatures made from certain other signing keys, aka a "verification DoS."

Timeline

dates in UTC
  1. 2025-03-1920:15CVE publishedNVD

Versions per branch

NVD
Gnupg
BranchAffectedFixed in
2.5≥ 2.5.0, < 2.5.52.5.5
2.4< 2.4.82.4.8

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As mitre, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • GnuPGother versions: not affected
    Affected
    • < 2.5.5fixed in 2.5.5semver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-03-19

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gnupgWolfiall versions · fixed in 2.4.8-r1and 12 other packages
  • gnupgMinimOSall versions · fixed in 2.4.8-r0and 12 other packages
  • gnupgChainguardall versions · fixed in 2.4.8-r1and 12 other packages
  • gnupg2Ubuntu:Pro:18.04:LTSall versions · fixed in 2.2.4-1ubuntu1.6+esm1
  • gnupg2Ubuntu:Pro:16.04:LTSall versions · fixed in 2.1.11-6ubuntu2.1+esm2
  • gnupg2Ubuntu:25.10all versions · fixed in 2.4.4-2ubuntu23
  • gnupg2Ubuntu:24.04:LTSall versions · fixed in 2.4.4-2ubuntu17.2
  • gnupg2Ubuntu:22.04:LTSall versions · fixed in 2.2.27-3ubuntu2.3

38 more package ranges on OSV.dev

Vendor advisories

  • CVE-2025-30258 Red Hat Product Security15 known affected

    gnupg: verification DoS due to a malicious subkey in the keyring

    gnupg2 as a component of Red Hat Enterprise Linux 10 · gnupg2-smime as a component of Red Hat Enterprise Linux 10 · gnupg2.src as a component of Red Hat Enterprise Linux 10 · +12 more

Full record on NVD

Fix

  1. Update Gnupg to 2.5.5 · 2.4.8
  2. Workaround from the vendor Red Hat Product Security CVE-2025-30258 · 15 productsThere is no available mitigation for this vulnerability. However as a general security procedure,users should exercise caution and avoid importing GnuPG certificates from untrusted or unverified sources. Only import certificates that are known to be legitimate and from trusted entities. Update to G…
  3. No fix available, says the vendor Red Hat Product Security CVE-2025-30258 · 6 productsFix deferred
  4. No fix planned, says the vendor Red Hat Product Security CVE-2025-30258 · 9 productsOut of support scope

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Published
2025-03-19
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-5rjg-pf4q-hgcr

Frequently asked questions

What is CVE-2025-30258?

In GnuPG before 2.5.5, if a user chooses to import a certificate with certain crafted subkey data that lacks a valid backsig or that has incorrect usage flags, the user loses the ability to verify signatures made from certain other signing keys, aka a "verification DoS."

Is CVE-2025-30258 actively exploited?

Active exploitation of CVE-2025-30258 has not been confirmed. Its EPSS score was 0.2% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2025-30258?

CVE-2025-30258 has a CVSS v3 base score of 4.7 (MEDIUM severity), with vector string CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H.

Running gnupg? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record