Skip to main content
Public proof of conceptFix available

CVE-2025-58057

A public proof of concept exists; no exploitation attested.

  • Published2025-09-04
  • Fixed in4.1.125.Final
  • WeaknessCWE-409

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.

Timeline

dates in UTC
  1. 2025-09-0410:42CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2025-58057?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2025-58057?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
netty-codec
BranchAffectedFixed in
4.1< 4.1.125.Final4.1.125.Final
Netty
BranchAffectedFixed in
4.2≥ 4.2.0, < 4.2.54.2.5
4.1< 4.1.1254.1.125
netty-codec-compression
BranchAffectedFixed in
4.2≥ 4.2.0.Alpha1, < 4.2.5.Final4.2.5.Final

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • netty
    Affected
    • = <= 4.1.124.Final, < 4.1.125.Finalno fix stated
    • = <= 4.2.4.Final, < 4.2.5.Finalno fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-09-03

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • airbyte-serverMinimOSall versions · fixed in 2.2.0-r0
  • akhqWolfiall versions · fixed in 0.26.0-r3
  • akhqWolfiall versions · fixed in 0.26.0-r4
  • akhqChainguardall versions · fixed in 0.26.0-r3
  • akhqChainguardall versions · fixed in 0.26.0-r4
  • apache-hiveCleanStartall versions · fixed in 3.1.3-r3
  • apache-hiveCleanStartall versions · fixed in 4.0.0-r0
  • apache-hiveCleanStartall versions · fixed in 4.2.0-r1

177 more package ranges on OSV.dev

Vendor advisories

  • CVE-2025-58057 Red Hat Product Security5 products fixed · 1 known affected

    netty-codec: netty-codec-compression: Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack

    netty-codec as a component of Red Hat JBoss Enterprise Application Platform Expansion Pack

  • RHSA-2026:3951 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: JBoss EAP XP 5.0 Update 4.0 release. See references for release notes.

  • RHSA-2025:23417 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Streams for Apache Kafka 3.1.0 release and security update

  • RHSA-2025:19077 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Streams for Apache Kafka 2.9.3 release and security update

  • RHSA-2025:17563 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Red Hat build of Quarkus 3.20.3 release and security update

  • RHSA-2025:17187 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Red Hat build of Quarkus 3.15.7 release and security update

Full record on NVD

Fix

  1. Update netty-codec to 4.1.125.Final
  2. Vendor fix Red Hat Product Security RHSA-2026:3951 · 1 productBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://docs.redhat.com/en/documentation/red_hat_jboss_enterprise_application_platform/8.0/html/jboss_eap_xp_5.0_upgrade_and_migration…
  3. Vendor fix Red Hat Product Security RHSA-2025:23417 · 1 productBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/articles/11258
  4. Workaround from the vendor Red Hat Product Security RHSA-2026:3951 · 1 productMitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
  5. No fix available, says the vendor Red Hat Product Security CVE-2025-58057 · 1 productAffected

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionpoc2025-09-04
  • OpenCVESSVC decisionpoc—
  • CNACVSS 4.06.9known since 2026-10-23
  • NVDCVSS 3.17.5read 2026-10-23
  • CNAweakness (CWE)CWE-409known since 2026-10-23
  • FIRST EPSSEPSS score0.6 %2026-11-03
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryMODERATE2025-09-03

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2025-09-04
Last Modified
2026-10-19
NVD status
Analyzed
GitHub Advisory
GHSA-3p8m-j85q-pgmj

Frequently asked questions

What is CVE-2025-58057?

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.

Is CVE-2025-58057 actively exploited?

A proof-of-concept exploit exists for CVE-2025-58057, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2025-58057?

CVE-2025-58057 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running netty-codec? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record