CVE-2025-5769
Reflected Cross-Site Scripting via Authentication Endpoint in Multiple WSO2 Products Allows Browser Redirection and UI Modification
No exploitation reported by the sources we read.
- Published2026-11-03
- WeaknessCWE-79
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
The authentication endpoint does not properly encode user-supplied input before rendering it within the web page. This lack of output encoding allows an attacker to inject malicious JavaScript payloads into the authentication flow, which are then executed by the victim's browser. By exploiting this vulnerability, an attacker can redirect the user's browser to a malicious website, modify the content of the web page displayed to the user, or exfiltrate information from the browser. However, due to the implementation of the httpOnly flag on session-related sensitive cookies, session hijacking and similar attacks are not possible.
Timeline
dates in UTC- 2026-11-0306:11CVE publishedCNA
Observed activity
isMalicious corpus · updated 2026-11-03 03:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2025-5769?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2025-5769?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
Products declared by the CNA
As WSO2, the CNA that assigned this CVE, declared them in the CVE record; versions as written. NVD lists no product for this CVE yet: this is the only product data so far.
- WSO2 API Control Planeother versions: not affectedAffected
- ≥ 4.5.0, < 4.5.0.11fixed in 4.5.0.11custom
- WSO2 API Managerother versions: not affectedAffected
- ≥ 3.2.0, < 3.2.0.430fixed in 3.2.0.430custom
- ≥ 3.2.1, < 3.2.1.50fixed in 3.2.1.50custom
- ≥ 4.1.0, < 4.1.0.212fixed in 4.1.0.212custom
- ≥ 4.2.0, < 4.2.0.150fixed in 4.2.0.150custom
- ≥ 4.3.0, < 4.3.0.63fixed in 4.3.0.63custom
- ≥ 4.4.0, < 4.4.0.26fixed in 4.4.0.26custom
- ≥ 4.5.0, < 4.5.0.10fixed in 4.5.0.10custom
Not affected < 3.2.0 (status unknown)
- WSO2 Identity Serverother versions: not affectedAffected
- ≥ 5.10.0, < 5.10.0.359fixed in 5.10.0.359custom
- ≥ 5.11.0, < 5.11.0.404fixed in 5.11.0.404custom
- ≥ 6.0.0, < 6.0.0.237fixed in 6.0.0.237custom
- ≥ 6.1.0, < 6.1.0.234fixed in 6.1.0.234custom
- ≥ 7.0.0, < 7.0.0.107fixed in 7.0.0.107custom
- ≥ 7.1.0, < 7.1.0.12fixed in 7.1.0.12custom
Not affected < 5.10.0 (status unknown)
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-03
Neither OSV.dev nor the vendor advisories we read list affected versions for CVE-2025-5769 yet.
Fix
No fix published by the sources we read yet. NVD record
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Published
- 2026-11-03
- Last Modified
- 2026-11-03
- NVD status
- Received
Frequently asked questions
What is CVE-2025-5769?
Is CVE-2025-5769 actively exploited?
What is the CVSS score for CVE-2025-5769?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.