CVE-2025-1397
Improper IDP Status Validation via JWT Bearer or SAML2 Bearer Grants in Multiple WSO2 Products Allows Access Token Issuance for Disabled Identity Providers
No exploitation reported by the sources we read.
- Published2026-11-03
- WeaknessCWE-862
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
When utilizing JWT Bearer or SAML2 Bearer grant types, the system fails to validate the status of the Identity Provider (IDP) before issuing access tokens. This oversight permits tokens to be generated even when the associated IDP has been disabled. A malicious actor could leverage this vulnerability to obtain access tokens by targeting a disabled IDP. This could enable them to bypass intended security controls and potentially access protected resources that should be inaccessible due to the IDP's disabled state.
Timeline
dates in UTC- 2026-11-0306:07CVE publishedCNA
Observed activity
isMalicious corpus · updated 2026-11-03 03:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2025-1397?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2025-1397?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
Products declared by the CNA
As WSO2, the CNA that assigned this CVE, declared them in the CVE record; versions as written. NVD lists no product for this CVE yet: this is the only product data so far.
- WSO2 Universal Gatewayother versions: not affectedAffected
- ≥ 4.5.0, < 4.5.0.10fixed in 4.5.0.10custom
- WSO2 Traffic Managerother versions: not affectedAffected
- ≥ 4.5.0, < 4.5.0.10fixed in 4.5.0.10custom
- WSO2 API Managerother versions: not affectedAffected
- ≥ 3.1.0, < 3.1.0.321fixed in 3.1.0.321custom
- ≥ 3.2.0, < 3.2.0.414fixed in 3.2.0.414custom
- ≥ 3.2.1, < 3.2.1.50fixed in 3.2.1.50custom
- ≥ 4.0.0, < 4.0.0.335fixed in 4.0.0.335custom
- ≥ 4.1.0, < 4.1.0.211fixed in 4.1.0.211custom
- ≥ 4.2.0, < 4.2.0.150fixed in 4.2.0.150custom
- ≥ 4.3.0, < 4.3.0.63fixed in 4.3.0.63custom
- ≥ 4.4.0, < 4.4.0.26fixed in 4.4.0.26custom
2 more version lines in the CVE record.
- WSO2 API Control Planeother versions: not affectedAffected
- ≥ 4.5.0, < 4.5.0.11fixed in 4.5.0.11custom
- WSO2 Identity Serverother versions: not affectedAffected
- ≥ 5.10.0, < 5.10.0.346fixed in 5.10.0.346custom
- ≥ 5.11.0, < 5.11.0.396fixed in 5.11.0.396custom
- ≥ 6.0.0, < 6.0.0.232fixed in 6.0.0.232custom
- ≥ 6.1.0, < 6.1.0.224fixed in 6.1.0.224custom
- ≥ 7.0.0, < 7.0.0.93fixed in 7.0.0.93custom
Not affected < 5.10.0 (status unknown)
- WSO2 Open Banking AMother versions: not affectedAffected
- ≥ 2.0.0, < 2.0.0.370fixed in 2.0.0.370custom
Not affected < 2.0.0 (status unknown)
4 more products in the CVE record.
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-03
Neither OSV.dev nor the vendor advisories we read list affected versions for CVE-2025-1397 yet.
Fix
No fix published by the sources we read yet. NVD record
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- Published
- 2026-11-03
- Last Modified
- 2026-11-03
- NVD status
- Received
Frequently asked questions
What is CVE-2025-1397?
Is CVE-2025-1397 actively exploited?
What is the CVSS score for CVE-2025-1397?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.