Skip to main content
No exploitation reportedFix availableAwaiting NVD analysis

CVE-2024-9143

Low-level invalid GF(2^m) parameters lead to OOB memory access

No exploitation reported by the sources we read.

  • Published2024-10-16
  • WeaknessCWE-125 · CWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Issue summary: Use of the low-level GF(2^m) elliptic curve APIs with untrusted explicit values for the field polynomial can lead to out-of-bounds memory reads or writes. Impact summary: Out of bound memory writes can lead to an application crash or even a possibility of a remote code execution, however, in all the protocols involving Elliptic Curve Cryptography that we're aware of, either only "named curves" are supported, or, if explicit curve parameters are supported, they specify an X9.62 encoding of binary (GF(2^m)) curves that can't represent problematic input values. Thus the likelihood of existence of a vulnerable application is low. In particular, the X9.62 encoding is used for ECC keys in X.509 certificates, so problematic inputs cannot occur in the context of processing X.509 certificates. Any problematic use-cases would have to be using an "exotic" curve encoding. The affected APIs include: EC_GROUP_new_curve_GF2m(), EC_GROUP_new_from_params(), and various supporting BN_GF2m_*() functions. Applications working with "exotic" explicit binary (GF(2^m)) curve parameters, that make it possible to represent invalid field polynomials with a zero constant term, via the above or similar APIs, may terminate abruptly as a result of reading or writing outside of array bounds. Remote code execution cannot easily be ruled out. The FIPS modules in 3.3, 3.2, 3.1 and 3.0 are not affected by this issue.

Timeline

dates in UTC
  1. 2024-10-1617:09CVE publishedCNA

Versions per branch

Products declared by the CNA1 product

As openssl, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • OpenSSLother versions: not affected
    Affected
    • ≥ 3.3.0, < 3.3.3fixed in 3.3.3semver
    • ≥ 3.2.0, < 3.2.4fixed in 3.2.4semver
    • ≥ 3.1.0, < 3.1.8fixed in 3.1.8semver
    • ≥ 3.0.0, < 3.0.16fixed in 3.0.16semver
    • ≥ 1.1.1, < 1.1.1zbfixed in 1.1.1zbcustom
    • ≥ 1.0.2, < 1.0.2zlfixed in 1.0.2zlcustom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-09-01

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • Openresty_jllJuliaall versions · fixed in 1.29.203+0
  • OpenSSL_jllJuliaall versions · fixed in 3.0.16+0
  • eco-dotnet-libssl-1.0Chainguardall versions · no fixed version listedand 1 other package
  • edk2Ubuntu:Pro:20.04:LTSall versions · no fixed version listed
  • edk2Ubuntu:Pro:18.04:LTSall versions · no fixed version listedand 3 other packages
  • edk2Ubuntu:Pro:16.04:LTSall versions · no fixed version listedand 2 other packages
  • edk2Ubuntu:24.04:LTSall versions · fixed in 2024.02-2ubuntu0.6
  • edk2Ubuntu:22.04:LTSall versions · fixed in 2022.02-3ubuntu0.22.04.4

59 more package ranges on OSV.dev

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2024-10-16
Last Modified
2026-11-06
NVD status
Undergoing Analysis
GitHub Advisory
GHSA-q764-r57m-9wp9

Frequently asked questions

What is CVE-2024-9143?

Issue summary: Use of the low-level GF(2^m) elliptic curve APIs with untrusted explicit values for the field polynomial can lead to out-of-bounds memory reads or writes. Impact summary: Out of bound memory writes can lead to an application crash or even a possibility of a remote code execution, however, in all the protocols involving Elliptic Curve Cryptography that we're aware of, either only "named curves" are supported, or, if explicit curve parameters are supported, they specify an X9.62 encoding of binary (GF(2^m)) curves that can't represent problematic input values. Thus the likelihood of existence of a vulnerable application is low. In particular, the X9.62 encoding is used for ECC keys in X.509 certificates, so problematic inputs cannot occur in the context of processing X.509 certificates. Any problematic use-cases would have to be using an "exotic" curve encoding. The affected APIs include: EC_GROUP_new_curve_GF2m(), EC_GROUP_new_from_params(), and various supporting BN_GF2m_*() functions. Applications working with "exotic" explicit binary (GF(2^m)) curve parameters, that make it possible to represent invalid field polynomials with a zero constant term, via the above or similar APIs, may terminate abruptly as a result of reading or writing outside of array bounds. Remote code execution cannot easily be ruled out. The FIPS modules in 3.3, 3.2, 3.1 and 3.0 are not affected by this issue.

Is CVE-2024-9143 actively exploited?

Active exploitation of CVE-2024-9143 has not been confirmed. Its EPSS score was 5.8% on 2026-11-06, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2024-9143?

CVE-2024-9143 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running OpenSSL? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record