Skip to main content
ExploitedIn CISA KEVFix available

CVE-2023-33246

Exploitation confirmed. First attested on 2023-09-06 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2023-05-24
  • Fixed in5.1.1 · 4.9.6
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Timeline

dates in UTC
  1. 2023-05-2415:15CVE publishedNVD
  2. 2023-09-06Added to the CISA KEV catalogCISA KEV
  3. 2023-09-06Listed as exploited by GCVEGCVE
  4. 2023-09-06Exploitation first reportedCISA KEV
  5. 2025-01-2920:30SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-33246?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-33246?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Apache rocketmq
BranchAffectedFixed in
5.x≥ 5.0.0, < 5.1.15.1.1
4.9< 4.9.64.9.6
4.x≥ 4.0.0, < 4.9.64.9.6

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Apache Software Foundation Apache RocketMQother versions: not affected
    Affected
    • ≤ 5.1.0no fix statedmaven

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-07-12

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Vendor advisories

  • CVE-2023-33246 Red Hat Product Security

    rocketmq: Apache RocketMQ Arbitrary Code Injection

Full record on NVD

Fix

  1. Update Apache rocketmq to 5.1.1 · 4.9.6
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2023-09-27

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/apache_rocketmq_update_configrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2023-09-06
Patch Due Date
2023-09-27
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-05-24
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-x3cq-8f32-5f63

Frequently asked questions

What is CVE-2023-33246?

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Is CVE-2023-33246 actively exploited?

Yes. CVE-2023-33246 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2023-09-27.

What is the CVSS score for CVE-2023-33246?

CVE-2023-33246 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running rocketmq? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record