Skip to main content
ExploitedIn CISA KEVFix available

CVE-2023-32315

Exploitation confirmed. First attested on 2023-08-24 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2023-05-26
  • Fixed in4.7.5 · 4.6.8
  • WeaknessCWE-22

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Timeline

dates in UTC
  1. 2023-05-2623:15CVE publishedNVD
  2. 2023-08-24Added to the CISA KEV catalogCISA KEV
  3. 2023-08-24Listed as exploited by GCVEGCVE
  4. 2023-08-24Exploitation first reportedCISA KEV
  5. 2025-02-0416:14SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-32315?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-32315?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Igniterealtime openfire
BranchAffectedFixed in
4.7≥ 4.7.0, < 4.7.54.7.5
4.6≥ 3.10.0, < 4.6.84.6.8

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • igniterealtime Openfire
    Affected
    • = >= 3.10.0, < 4.6.8no fix stated
    • = >= 4.7.0, < 4.7.5no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-07-19

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • openfireCleanStartall versions · fixed in 4.7.5-r0
  • openfireAlpine:v3.20from 3.10.0 · fixed in 4.7.5-r0
  • openfireAlpine:v3.19from 3.10.0 · fixed in 4.7.5-r0
  • openfireAlpine:v3.18from 3.10.0 · fixed in 4.7.5-r0

Full record on NVD

Fix

  1. Update Igniterealtime openfire to 4.7.5 · 4.6.8
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2023-09-14

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/openfire_auth_bypass_rce_cve_2023_32315rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2023-08-24
Patch Due Date
2023-09-14
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2023-05-26
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-gw42-f939-fhvm

Frequently asked questions

What is CVE-2023-32315?

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Is CVE-2023-32315 actively exploited?

Yes. CVE-2023-32315 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2023-09-14.

What is the CVSS score for CVE-2023-32315?

CVE-2023-32315 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Running openfire? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record