Skip to main content
Public proof of conceptFix available

CVE-2023-28879

A public proof of concept exists; no exploitation attested.

  • Published2023-03-31
  • WeaknessCWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

Timeline

dates in UTC
  1. 2023-03-3117:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-28879?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-28879?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Debian debian linux
BranchAffectedFixed in
10.0= 10.0no fix published
11.0= 11.0no fix published
Artifex ghostscript
BranchAffectedFixed in
10.1< 10.01.010.01.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • ghostscriptUbuntu:Pro:16.04:LTSall versions · fixed in 9.26~dfsg+0-0ubuntu0.16.04.14+esm5
  • ghostscriptUbuntu:22.04:LTSall versions · fixed in 9.55.0~dfsg1-0ubuntu5.2
  • ghostscriptUbuntu:20.04:LTSall versions · fixed in 9.50~dfsg-5ubuntu4.7
  • ghostscriptUbuntu:18.04:LTSall versions · fixed in 9.26~dfsg+0-0ubuntu0.18.04.18
  • ghostscriptTuxCare:RHEL:7all versions · fixed in 9.25-5.0.1.el7.tuxcare.els2and 5 other packages
  • ghostscriptTuxCare:OracleLinux:7all versions · fixed in 9.25-5.0.1.el7.tuxcare.els2and 5 other packages
  • ghostscriptTuxCare:CentOS:8.5all versions · fixed in 9.27-1.el8_5.tuxcare.els1and 8 other packages
  • ghostscriptTuxCare:CentOS:7all versions · fixed in 9.25-5.0.1.el7.tuxcare.els2and 5 other packages

49 more package ranges on OSV.dev

Vendor advisories

  • CVE-2023-28879 Red Hat Product Security234 products fixed · 22 known affected

    ghostscript: buffer overflow in base/sbcp.c leading to data corruption

    ghostscript as a component of Red Hat Enterprise Linux 6 · ghostscript-devel as a component of Red Hat Enterprise Linux 6 · ghostscript-doc as a component of Red Hat Enterprise Linux 6 · +19 more

  • RHSA-2023:7053 Red Hat Product Security82 products fixed

    Red Hat Security Advisory: ghostscript security and bug fix update

  • RHSA-2023:6544 Red Hat Product Security85 products fixed

    Red Hat Security Advisory: ghostscript security and bug fix update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2023:7053 · 82 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. No fix planned, says the vendor Red Hat Product Security CVE-2023-28879 · 13 productsOut of support scope
  3. No fix planned, says the vendor Red Hat Product Security CVE-2023-28879 · 9 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-03-31
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-6mcj-frmm-wmr5

Frequently asked questions

What is CVE-2023-28879?

In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

Is CVE-2023-28879 actively exploited?

A proof-of-concept exploit exists for CVE-2023-28879, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2023-28879?

CVE-2023-28879 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running ghostscript? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record