Skip to main content
Public proof of conceptFix available

CVE-2018-17961

A public proof of concept exists; no exploitation attested.

  • Published2018-10-15
  • WeaknessCWE-209

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving errorhandler setup. NOTE: this issue exists because of an incomplete fix for CVE-2018-17183.

Timeline

dates in UTC
  1. 2018-10-09Exploit-DB entryExploit-DB
  2. 2018-10-1516:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-17961?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-17961?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
18.10= 18.10no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
9.0= 9.0no fix published
Artifex ghostscript
BranchAffectedFixed in
9.25< 9.259.25

6 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • ghostscriptUbuntu:18.04:LTSall versions · fixed in 9.25~dfsg+1-0ubuntu0.18.04.2
  • ghostscriptUbuntu:16.04:LTSall versions · fixed in 9.25~dfsg+1-0ubuntu0.16.04.2
  • ghostscriptUbuntu:14.04:LTSall versions · fixed in 9.25~dfsg+1-0ubuntu0.14.04.2
  • ghostscriptSUSE:OpenStack Cloud 7all versions · fixed in 9.26-23.16.1
  • ghostscriptSUSE:Linux Enterprise Software Development Kit 12 SP4all versions · fixed in 9.26-23.16.1
  • ghostscriptSUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 9.26-23.16.1
  • ghostscriptSUSE:Linux Enterprise Server for SAP Applications 12 SP4all versions · fixed in 9.26-23.16.1
  • ghostscriptSUSE:Linux Enterprise Server for SAP Applications 12 SP3all versions · fixed in 9.26-23.16.1

61 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-17961 Red Hat Product Security360 products fixed · 6 known affected

    ghostscript: Saved execution stacks can leak operator arrays (incomplete fix for CVE-2018-17183)

    ghostscript as a component of Red Hat Enterprise Linux 5 · ghostscript as a component of Red Hat Enterprise Linux 6 · ghostscript-devel as a component of Red Hat Enterprise Linux 6 · +3 more

  • RHSA-2018:3834 Red Hat Product Security98 products fixed

    Red Hat Security Advisory: ghostscript security and bug fix update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2018:3834 · 98 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. Workaround from the vendor Red Hat Product Security RHSA-2018:3834 · 98 productsPlease refer to the "Mitigation" section of CVE-2018-16509 : https://access.redhat.com/security/cve/cve-2018-16509
  3. No fix planned, says the vendor Red Hat Product Security CVE-2018-17961 · 6 productsWill not fix

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-45573
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedmatlink/CVE-2018-17961
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.08.6read 2026-10-23
  • NVDCVSS 2.06.8read 2026-10-23
  • NVDweakness (CWE)CWE-209read 2026-10-23
  • FIRST EPSSEPSS score10.0 %2026-11-03
  • PoC-in-GitHubproof of concept1read 2026-11-03
  • Exploit-DBdetectionread 2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Published
2018-10-15
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-17961?

Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving errorhandler setup. NOTE: this issue exists because of an incomplete fix for CVE-2018-17183.

Is CVE-2018-17961 actively exploited?

Active exploitation of CVE-2018-17961 has not been confirmed. Its EPSS score was 10.0% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-17961?

CVE-2018-17961 has a CVSS v3 base score of 8.6 (HIGH severity), with vector string CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H.

Running ghostscript? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record