Skip to main content
Public proof of conceptFix available

CVE-2023-27372

A public proof of concept exists; no exploitation attested.

  • Published2023-02-28
  • Fixed in4.1.8 · 4.0.10 · 3.2.18
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Timeline

dates in UTC
  1. 2023-02-2820:15CVE publishedNVD
  2. 2023-06-20Exploit-DB entryExploit-DB

Versions per branch

NVD
Spip
BranchAffectedFixed in
4.1≥ 4.1.0, < 4.1.84.1.8
4.0≥ 4.0.0, < 4.0.104.0.10
3.2< 3.2.183.2.18
4.2= 4.2.0no fix published
Debian debian linux
BranchAffectedFixed in
11.0= 11.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • spipUbuntu:Pro:20.04:LTSall versions · fixed in 3.2.7-1ubuntu0.1+esm2
  • spipUbuntu:Pro:18.04:LTSall versions · fixed in 3.1.4-4~deb9u5ubuntu0.1~esm2
  • spipUbuntu:Pro:16.04:LTSall versions · no fixed version listed
  • spipUbuntu:22.04:LTSall versions · no fixed version listed
  • spipDebian:14all versions · fixed in 4.1.8+dfsg-1
  • spipDebian:13all versions · fixed in 4.1.8+dfsg-1
  • spipDebian:11all versions · fixed in 3.2.11-3+deb11u7
  • spipDebian:10all versions · fixed in 3.2.4-1+deb10u10

Full record on NVD

Fix

  1. Update Spip to 4.1.8 · 4.0.10 · 3.2.18

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-51536
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/spip_rce_formrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-02-28
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-jc3f-vxgp-6jw9

Frequently asked questions

What is CVE-2023-27372?

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Is CVE-2023-27372 actively exploited?

A proof-of-concept exploit exists for CVE-2023-27372, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2023-27372?

CVE-2023-27372 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running spip? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record