Skip to main content
Public proof of conceptFix available

CVE-2016-7981

A public proof of concept exists; no exploitation attested.

  • Published2017-01-18
  • WeaknessCWE-79

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Cross-site scripting (XSS) vulnerability in valider_xml.php in SPIP 3.1.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the var_url parameter in a valider_xml action.

Timeline

dates in UTC
  1. 2017-01-1817:59CVE publishedNVD

Versions per branch

NVD
Spip
BranchAffectedFixed in
3.1≤ 3.1.2no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • spipUbuntu:Pro:16.04:LTSall versions · no fixed version listed
  • spipDebian:14all versions · fixed in 3.1.3-1
  • spipDebian:13all versions · fixed in 3.1.3-1
  • spipDebian:7all versions · fixed in 2.1.17-1+deb7u6

Full record on NVD

Fix

Advisories and patches

Detection

read 2026-11-04 22:56 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.06.1read 2026-10-23
  • NVDCVSS 2.04.3read 2026-10-23
  • NVDweakness (CWE)CWE-79read 2026-10-23
  • FIRST EPSSEPSS score8.2 %2026-11-04
  • ProjectDiscoverydetectionread 2026-11-04
  • OSVaffected packages—

Identifiers

  • EUVD-2016-8829same flawENISA EUVD · LicenseRef-ENISA-legal-notice
  • DLA-695-1advisory covering several CVEsDebian · LicenseRef-unstated

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
2017-01-18
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2016-7981?

Cross-site scripting (XSS) vulnerability in valider_xml.php in SPIP 3.1.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the var_url parameter in a valider_xml action.

Is CVE-2016-7981 actively exploited?

Active exploitation of CVE-2016-7981 has not been confirmed. Its EPSS score was 8.2% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-7981?

CVE-2016-7981 has a CVSS v3 base score of 6.1 (MEDIUM severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.

Running spip? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record