Skip to main content
Public proof of conceptFix available

CVE-2023-2640

A public proof of concept exists; no exploitation attested.

  • Published2023-07-26
  • Fixed in6.2.0-26.26 · 6.0.0-1020.20 · 5.4.0-155.172
  • WeaknessCWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

On Ubuntu kernels carrying both c914c0e27eb0 and "UBUNTU: SAUCE: overlayfs: Skip permission checking for trusted.overlayfs.* xattrs", an unprivileged user may set privileged extended attributes on the mounted files, leading them to be set on the upper files without the appropriate security checks.

Timeline

dates in UTC
  1. 2023-07-2602:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-2640?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-2640?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

CISA-ADP · NVD
Canonical ubantu kernel
BranchAffectedFixed in
6.2< 6.2.0-26.266.2.0-26.26
6.0< 6.0.0-1020.206.0.0-1020.20
5.4< 5.4.0-155.1725.4.0-155.172
Canonical ubuntu linux
BranchAffectedFixed in
23.4= 23.04no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As canonical, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Canonical Ubuntu Kernelother versions: not affected

    package Linuxplatforms: Linux

    Not affected < 6.2.0-26.26 · < 6.0.0-1020.20 · < 5.4.0-155.172

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-07-26

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • linuxUbuntu:Pro:20.04:LTSall versions · no fixed version listedand 10 other packages
  • linuxUbuntu:Pro:18.04:LTSall versions · no fixed version listedand 12 other packages
  • linuxUbuntu:Pro:16.04:LTSall versions · no fixed version listedand 7 other packages
  • linuxUbuntu:Pro:14.04:LTSall versions · no fixed version listedand 3 other packages
  • linuxUbuntu:22.04:LTSall versions · fixed in 5.15.0-177.187and 1 other package
  • linux-awsUbuntu:22.04:LTSall versions · fixed in 5.15.0-1106.113
  • linux-aws-5.15Ubuntu:Pro:20.04:LTSall versions · fixed in 5.15.0-1106.113~20.04.1
  • linux-aws-5.19Ubuntu:22.04:LTSall versions · fixed in 5.19.0-1029.30~22.04.1

51 more package ranges on OSV.dev

Vendor advisories

  • CVE-2023-2640 Red Hat Product Security

    kernel: overlayfs: In Ubuntu skip permission checking for trusted.overlayfs.* xattrs

Full record on NVD

Fix

  1. Update Canonical ubantu kernel to 6.2.0-26.26 · 6.0.0-1020.20 · 5.4.0-155.172

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/local/gameoverlay_privescrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2023-07-26
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-38f7-vv5r-859m

Frequently asked questions

What is CVE-2023-2640?

On Ubuntu kernels carrying both c914c0e27eb0 and "UBUNTU: SAUCE: overlayfs: Skip permission checking for trusted.overlayfs.* xattrs", an unprivileged user may set privileged extended attributes on the mounted files, leading them to be set on the upper files without the appropriate security checks.

Is CVE-2023-2640 actively exploited?

Active exploitation of CVE-2023-2640 has not been confirmed. Its EPSS score was 15.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-2640?

CVE-2023-2640 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running Linux kernel? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record