Skip to main content
ExploitedIn CISA KEVFix available

CVE-2021-3493

Exploitation confirmed. First attested on 2022-10-20 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2021-04-17
  • Fixed in20.10 · 20.04 · 18.04
  • WeaknessCWE-270 · CWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The overlayfs implementation in the linux kernel did not properly validate with respect to user namespaces the setting of file capabilities on files in an underlying file system. Due to the combination of unprivileged user namespaces along with a patch carried in the Ubuntu kernel to allow unprivileged overlay mounts, an attacker could use this to gain elevated privileges.

Timeline

dates in UTC
  1. 2021-04-1705:15CVE publishedNVD
  2. 2022-10-20Added to the CISA KEV catalogCISA KEV
  3. 2022-10-20Listed as exploited by GCVEGCVE
  4. 2022-10-20Exploitation first reportedCISA KEV
  5. 2025-02-0712:30SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-3493?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-3493?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
20.10< 20.1020.10
20.4≥ 18.04.1, < 20.0420.04
18.4< 18.0418.04

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As canonical, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Ubuntu linux kernel
    Affected
    • ≥ 5.8 kernel, < 5.8.0-50.56fixed in 5.8.0-50.56custom
    • ≥ 5.4 kernel, < 5.4.0-72.80fixed in 5.4.0-72.80custom
    • ≥ 4.15 kernel, < 4.15.0-142.146fixed in 4.15.0-142.146custom
    • ≥ 4.4 kernel, < 4.4.0-209.241fixed in 4.4.0-209.241custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-12-03

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • linuxUbuntu:Pro:20.04:LTSall versions · fixed in 5.4.0-72.80
  • linuxUbuntu:Pro:18.04:LTSall versions · fixed in 4.15.0-142.146
  • linuxUbuntu:Pro:16.04:LTSall versions · fixed in 4.4.0-209.241
  • linuxUbuntu:20.04:LTSall versions · fixed in 5.4.0-72.80
  • linuxUbuntu:18.04:LTSall versions · fixed in 4.15.0-142.146
  • linuxUbuntu:16.04:LTSall versions · fixed in 4.4.0-209.241
  • linuxDebian:14all versions · fixed in 5.10.38-1
  • linuxDebian:13all versions · fixed in 5.10.38-1

73 more package ranges on OSV.dev

Vendor advisories

  • CVE-2021-3493 Red Hat Product Security

    kernel: overlayfs file system caps privilege escalation

Full record on NVD

Fix

  1. Update Canonical ubuntu linux to 20.10 · 20.04 · 18.04
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-11-10

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/local/cve_2021_3493_overlayfsrank: greatModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-10-20
Patch Due Date
2022-11-10
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2021-04-17
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-2fj2-4h38-3c72

Frequently asked questions

What is CVE-2021-3493?

The overlayfs implementation in the linux kernel did not properly validate with respect to user namespaces the setting of file capabilities on files in an underlying file system. Due to the combination of unprivileged user namespaces along with a patch carried in the Ubuntu kernel to allow unprivileged overlay mounts, an attacker could use this to gain elevated privileges.

Is CVE-2021-3493 actively exploited?

Yes. CVE-2021-3493 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-11-10.

What is the CVSS score for CVE-2021-3493?

CVE-2021-3493 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running Linux kernel? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record