Skip to main content
Exploitation reportedNot in CISA KEV yetFix available

CVE-2023-22809

Exploitation reported by one source. First attested on 2026-04-15 by GCVE · kevintel.

  • Published2023-01-18
  • WeaknessCWE-269

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.

Timeline

dates in UTC
  1. 2023-01-1817:15CVE publishedNVD
  2. 2023-04-03Exploit-DB entryExploit-DB
  3. 2026-04-1514:28Listed as exploited by GCVEGCVE
  4. 2026-04-1514:28Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-22809?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-22809?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Debian debian linux
BranchAffectedFixed in
10.0= 10.0no fix published
11.0= 11.0no fix published
Fedoraproject fedora
BranchAffectedFixed in
36.x= 36no fix published
37.x= 37no fix published
Sudo project sudo
BranchAffectedFixed in
1.x≥ 1.8.0, < 1.9.121.9.12
1.9= 1.9.12no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • redhat-virtualization-hostRed Hat:rhev_hypervisor:4.4::el8all versions · fixed in 0:4.5.3-202302150956_8.6and 1 other package
  • sudoUbuntu:Pro:16.04:LTSall versions · fixed in 1.8.16-0ubuntu1.10+esm1
  • sudoUbuntu:Pro:14.04:LTSall versions · fixed in 1.8.9p5-1ubuntu1.5+esm7
  • sudoUbuntu:22.04:LTSall versions · fixed in 1.9.9-1ubuntu2.2
  • sudoUbuntu:20.04:LTSall versions · fixed in 1.8.31-1ubuntu1.4
  • sudoUbuntu:18.04:LTSall versions · fixed in 1.8.21p2-3ubuntu1.5
  • sudoTuxCare:Ubuntu:16.04all versions · fixed in 1.8.16-0ubuntu1.11+tuxcare.els1and 1 other package
  • sudoTuxCare:OracleLinux:6all versions · fixed in 1.8.6p3-32.el6.tuxcare.els1and 1 other package

83 more package ranges on OSV.dev

Vendor advisories

  • CVE-2023-22809 Red Hat Product Security224 products fixed

    sudo: arbitrary file write with privileges of the RunAs user

  • ICSA-25-105-08 CISA2 known affected

    ABB M2M Gateway

    ABB M2M Gateway ARM600, firmware versions = 4.1.2 <= 5.0.3 · ABB M2M Gateway SW, software versions = 5.0.1 <= 5.0.3

  • RHSA-2023:3276 Red Hat Product Security25 products fixed

    Red Hat Security Advisory: sudo security update

  • RHSA-2023:3262 Red Hat Product Security7 products fixed

    Red Hat Security Advisory: sudo security update

  • RHSA-2023:3264 Red Hat Product Security7 products fixed

    Red Hat Security Advisory: sudo security update

  • RHSA-2023:0859 Red Hat Product Security2 products fixed

    Red Hat Security Advisory: Red Hat Virtualization Host 4.4.z SP 1 security update batch#4 (oVirt-4.5.3-4)

9 more advisories

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2023:3276 · 25 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. Vendor fix Red Hat Product Security RHSA-2023:0859 · 2 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
  3. Workaround from the vendor Red Hat Product Security RHSA-2023:3276 · 25 productsIt is possible to prevent a user-specified editor from being used by sudoedit by adding the following line to the sudoers file. ~~~ Defaults!sudoedit env_delete+="SUDO_EDITOR VISUAL EDITOR" ~~~ To restrict the editor when editing specific files, a Cmnd_Alias can be used, for example: ~~~ Cmnd_A…
  4. Mitigation from the vendor CISA ICSA-25-105-08 · 2 productsMitigating factors describe conditions and circumstances that make an attack that exploits the vulnerability difficult or less likely to succeed. The following mitigations are recommended. 1. Obtain a cellular private access point (APN). A dedicated private cellular access point and respective SIM…

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-51217
Exploit-DB
Metasploit modules
1 moduleexploit/linux/local/sudoedit_bypass_priv_escrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2023-01-18
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-3vwp-294x-6v9c

Frequently asked questions

What is CVE-2023-22809?

In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.

Is CVE-2023-22809 actively exploited?

Active exploitation of CVE-2023-22809 has not been confirmed. Its EPSS score was 55.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-22809?

CVE-2023-22809 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running sudo? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record