Skip to main content
Public proof of conceptFix available

CVE-2022-3360

A public proof of concept exists; no exploitation attested.

  • Published2022-10-31
  • Fixed in4.1.7.2
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to remote code execution (RCE). To successfully exploit this vulnerability attackers must have knowledge of the site secrets, allowing them to generate a valid hash via the wp_hash() function.

Timeline

dates in UTC
  1. 2022-10-3116:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-3360?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-3360?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Thimpress learnpress
BranchAffectedFixed in
4.1< 4.1.7.24.1.7.2

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As WPScan, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Unknown LearnPress – WordPress LMS Plugin
    Affected
    • ≥ 4.1.7.2, < 4.1.7.2fixed in 4.1.7.2custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-10-31

Fix

  1. Update Thimpress learnpress to 4.1.7.2

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-10-31
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-7h2h-qrhm-554p

Frequently asked questions

What is CVE-2022-3360?

The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to remote code execution (RCE). To successfully exploit this vulnerability attackers must have knowledge of the site secrets, allowing them to generate a valid hash via the wp_hash() function.

Is CVE-2022-3360 actively exploited?

A proof-of-concept exploit exists for CVE-2022-3360, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-3360?

CVE-2022-3360 has a CVSS v3 base score of 8.1 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record