Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2022-31137

Exploitation confirmed. First attested on 2025-06-03 by GCVE · kevintel, GCVE · shadowserver.

  • Published2022-07-08
  • Fixed in6.1.1.0
  • WeaknessCWE-78

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Versions prior to 6.1.1.0 are subject to a remote code execution vulnerability. System commands can be run remotely via the subprocess_execute function without processing the inputs received from the user in the /app/options.py file. Attackers need not be authenticated to exploit this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

dates in UTC
  1. 2022-07-0820:15CVE publishedNVD
  2. 2025-06-0311:09Listed as exploited by GCVEGCVE
  3. 2025-06-0311:09Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-31137?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-31137?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Roxy-wi
BranchAffectedFixed in
6.1< 6.1.1.06.1.1.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • hap-wi roxy-wi
    Affected
    • = < 6.1.1.0no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-05-24

Fix

  1. Update Roxy-wi to 6.1.1.0

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/linux/http/roxy_wi_execrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • GCVEexploitation2025-06-03
  • CISA-ADPSSVC decisionpoc2025-04-22
  • OpenCVESSVC decisionpoc—
  • CNACVSS 3.110known since 2026-10-23
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.010read 2026-10-23
  • CNAweakness (CWE)CWE-78known since 2026-10-23
  • NVDweakness (CWE)CWE-78read 2026-10-23
  • FIRST EPSSEPSS score90.6 %read 2026-11-03
  • ProjectDiscoverydetectionread 2026-11-03
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-07-08
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2022-31137?

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Versions prior to 6.1.1.0 are subject to a remote code execution vulnerability. System commands can be run remotely via the subprocess_execute function without processing the inputs received from the user in the /app/options.py file. Attackers need not be authenticated to exploit this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Is CVE-2022-31137 actively exploited?

A proof-of-concept exploit exists for CVE-2022-31137, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-31137?

CVE-2022-31137 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record