Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2022-31126

Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.

  • Published2022-07-06
  • Fixed in6.1.1.0
  • WeaknessCWE-74

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to code execution by sending a specially crafted HTTP request to /app/options.py file. This affects Roxy-wi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.

Timeline

dates in UTC
  1. 2022-07-0618:15CVE publishedNVD
  2. 2023-04-03Exploit-DB entryExploit-DB
  3. 2023-10-1414:57Listed as exploited by GCVEGCVE
  4. 2023-10-1414:57Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-31126?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-31126?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Roxy-wi
BranchAffectedFixed in
6.1< 6.1.1.06.1.1.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • hap-wi roxy-wi
    Affected
    • = < 6.1.1.0no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-07-06

Fix

  1. Update Roxy-wi to 6.1.1.0

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-51227
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • GCVEexploitation2023-10-14
  • CISA-ADPSSVC decisionnone2025-04-23
  • OpenCVESSVC decisionnone—
  • CNACVSS 3.110known since 2026-10-23
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-74known since 2026-10-23
  • FIRST EPSSEPSS score52.6 %read 2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • ProjectDiscoverydetectionread 2026-11-02

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-07-06
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2022-31126?

Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to code execution by sending a specially crafted HTTP request to /app/options.py file. This affects Roxy-wi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.

Is CVE-2022-31126 actively exploited?

Active exploitation of CVE-2022-31126 has not been confirmed. Its EPSS score was 52.6% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2022-31126?

CVE-2022-31126 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record