Skip to main content
Public proof of conceptFix available

CVE-2022-2992

A public proof of concept exists; no exploitation attested.

  • Published2022-10-17
  • Fixed in15.3.2 · 15.2.4 · 15.1.6
  • WeaknessCWE-74

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated user to achieve remote code execution via the Import from GitHub API endpoint.

Timeline

dates in UTC
  1. 2022-10-1716:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-2992?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-2992?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
GitLab
BranchAffectedFixed in
15.3≥ 15.3, < 15.3.215.3.2
15.3≥ 15.3.0, < 15.3.215.3.2
15.2≥ 15.2, < 15.2.415.2.4
15.2≥ 15.2.0, < 15.2.415.2.4
15.1≥ 11.10, < 15.1.615.1.6
15.1≥ 11.10.0, < 15.1.615.1.6

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitLab, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • GitLab
    Affected
    • = >=11.10, <15.1.6no fix stated
    • = >=15.2, <15.2.4no fix stated
    • = >=15.3, <15.3.2no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-02-15

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gitlabUbuntu:16.04:LTSall versions · no fixed version listed

Full record on NVD

Fix

  1. Update GitLab to 15.3.2 · 15.2.4 · 15.1.6

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedCsEnox/CVE-2022-2992Malwareman007/CVE-2022-2992
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/gitlab_github_import_rce_cve_2022_2992rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Published
2022-10-17
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-m7f3-552r-pf23

Frequently asked questions

What is CVE-2022-2992?

A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated user to achieve remote code execution via the Import from GitHub API endpoint.

Is CVE-2022-2992 actively exploited?

A proof-of-concept exploit exists for CVE-2022-2992, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-2992?

CVE-2022-2992 has a CVSS v3 base score of 9.9 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H.

Running GitLab? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record