Skip to main content
ExploitedIn CISA KEVFix available

CVE-2021-39935

Exploitation confirmed. First attested on 2026-02-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2021-12-13
  • Fixed in14.5.2 · 14.4.4 · 14.3.6
  • WeaknessCWE-918

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API

Timeline

dates in UTC
  1. 2021-12-1316:15CVE publishedNVD
  2. 2026-02-03Added to the CISA KEV catalogCISA KEV
  3. 2026-02-03Listed as exploited by GCVEGCVE
  4. 2026-02-03Exploitation first reportedCISA KEV
  5. 2026-02-0315:23SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-39935?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-39935?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
GitLab
BranchAffectedFixed in
14.5≥ 14.5.0, < 14.5.214.5.2
14.4≥ 14.4.0, < 14.4.414.4.4
14.3≥ 10.5.0, < 14.3.614.3.6

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitLab, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • GitLab
    Affected
    • = >=10.5, <14.3.6no fix stated
    • = >=14.4, <14.4.4no fix stated
    • = >=14.5, <14.5.2no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-12-13

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gitlabUbuntu:16.04:LTSall versions · no fixed version listed

Full record on NVD

Fix

  1. Update GitLab to 14.5.2 · 14.4.4 · 14.3.6
  2. CISA’s required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.due 2026-02-24

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2026-02-03
Patch Due Date
2026-02-24
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2021-12-13
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-22hj-9cx7-p2hw

Frequently asked questions

What is CVE-2021-39935?

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API

Is CVE-2021-39935 actively exploited?

Yes. CVE-2021-39935 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2026-02-24.

What is the CVSS score for CVE-2021-39935?

CVE-2021-39935 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Running GitLab? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record