Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-24086

Exploitation confirmed. First attested on 2022-02-15 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2022-02-16
  • Fixed in2.3.0
  • WeaknessCWE-20

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.

Timeline

dates in UTC
  1. 2022-02-15Added to the CISA KEV catalogCISA KEV
  2. 2022-02-15Listed as exploited by GCVEGCVE
  3. 2022-02-15Exploitation first reportedCISA KEV
  4. 2022-02-1617:15CVE publishedNVD
  5. 2024-02-2718:35SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-24086?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-24086?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Magento
BranchAffectedFixed in
2.3< 2.3.02.3.0
2.3≥ 2.3.3, ≤ 2.3.6no fix published
2.4≥ 2.4.0, ≤ 2.4.2no fix published
2.3= 2.3.7no fix published
2.4= 2.4.3no fix published
2.3≥ 2.3.7-p1, ≤ 2.3.7-p1no fix published
2.3≥ 2.3.7-p2, ≤ 2.3.7-p2no fix published
2.4≥ 2.4.3, ≤ 2.4.3no fix published
2.4≥ 2.4.3-p1, ≤ 2.4.3-p1no fix published
Adobe magento
BranchAffectedFixed in
2.3< 2.3.02.3.0
2.3> 2.3.3, ≤ 2.3.6no fix published
2.4≥ 2.4.0, ≤ 2.4.2no fix published
2.3= 2.3.7no fix published
2.4= 2.4.3no fix published
magento/community-edition
BranchAffectedFixed in
2.4≥ 2.4.0, < 2.4.3-p22.4.3-p2
2.3≥ 2.3.3-p1, < 2.3.7-p32.3.7-p3

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As adobe, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Adobe Magento Commerce
    Affected
    • ≤ 2.4.3-p1no fix statedcustom
    • ≤ 2.3.7-p2no fix statedcustom
    • ≤ Noneno fix statedcustom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-02-16

Fix

  1. Update Magento to 2.3.0
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-03-01

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-02-15
Patch Due Date
2022-03-01
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-02-16
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-f8fv-f786-9933

Frequently asked questions

What is CVE-2022-24086?

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.

Is CVE-2022-24086 actively exploited?

Yes. CVE-2022-24086 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-03-01.

What is the CVSS score for CVE-2022-24086?

CVE-2022-24086 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record